aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2015-01-07 18:32:36 -0800
committerArmin Kuster <akuster808@gmail.com>2015-03-21 07:48:13 -0700
commit0a787c6745e14449b1278a762b2d6bc1bc5cbcc4 (patch)
tree24c9e9a77db350c4290dbc48bcf89f2cb345b046 /meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb
parent4a054e43a6f1d16d5798c48421ef731fb9f94d38 (diff)
downloadmeta-openembedded-contrib-0a787c6745e14449b1278a762b2d6bc1bc5cbcc4.tar.gz
wireshark: update to 1.12.3
The following vulnerabilities have been fixed. * [1]wnpa-sec-2015-01 The WCCP dissector could crash. ([2]Bug 10720, ws-buglink:10806) CVE-2015-0559, CVE-2015-0560 * [3]wnpa-sec-2015-02 The LPP dissector could crash. ([4]Bug 10773) CVE-2015-0561 * [5]wnpa-sec-2015-03 The DEC DNA Routing Protocol dissector could crash. ([6]Bug 10724) CVE-2015-0562 * [7]wnpa-sec-2015-04 The SMTP dissector could crash. ([8]Bug 10823) CVE-2015-0563 * wnpa-sec-2015-05 Wireshark could crash while decypting TLS/SSL sessions. Discovered by Noam Rathaus. CVE-2015-0564 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb')
-rw-r--r--meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb b/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb
new file mode 100644
index 0000000000..2dd99d6986
--- /dev/null
+++ b/meta-networking/recipes-support/wireshark/wireshark_1.12.3.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "wireshark - a popular network protocol analyzer"
+HOMEPAGE = "http://www.wireshark.org"
+SECTION = "network"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0"
+
+DEPENDS = "perl-native libcap libpcap pcre expat glib-2.0 libnl sbc"
+
+SRC_URI = " \
+ http://wiresharkdownloads.riverbed.com/wireshark/src/wireshark-${PV}.tar.bz2 \
+ file://Do-not-set-CC_FOR_BUILD-flags.patch \
+"
+
+PE = "1"
+
+SRC_URI[md5sum] = "e6318b8451d4e56d39bd911da296ef19"
+SRC_URI[sha256sum] = "69950b9dcb1a630982b5f680554d73d27ee0dc856fc6aeef88c8d04eb5ac33ea"
+
+inherit autotools pkgconfig
+
+ARM_INSTRUCTION_SET = "arm"
+
+# Works with either gtk+ or gtk3.
+WHICH_GTK = "gtk3"
+
+PACKAGECONFIG ??= "gnutls gcrypt"
+PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "${WHICH_GTK} graphics", "", d)}"
+PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "ipv6", "ipv6", "", d)}"
+
+PACKAGECONFIG[libsmi] = "--with-libsmi=yes, --with-libsmi=no, libsmi"
+PACKAGECONFIG[portaudio] = "--with-portaudio=yes, --with-portaudio=no, portaudio-v19"
+PACKAGECONFIG[gtk2] = "--with-gtk2=yes, --with-gtk2=no, gtk+"
+PACKAGECONFIG[gtk3] = "--with-gtk3=yes, --with-gtk3=no, gtk+3"
+PACKAGECONFIG[graphics] = "--enable-wireshark, --disable-wireshark,"
+PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
+PACKAGECONFIG[gnutls] = "--with-gnutls=yes, --with-gnutls=no, gnutls"
+PACKAGECONFIG[gcrypt] = "--with-gcrypt=yes, --with-gcrypt=no, libgcrypt"
+PACKAGECONFIG[krb5] = "--with-krb5=yes, --with-krb5=no, krb5"
+
+EXTRA_OECONF = "--with-qt=no --enable-usr-local=no --enable-tshark --with-c-ares=no"
+
+do_configure_prepend() {
+ # force to use fallback
+ sed -i -e '/^glib_prefix/s/=.*$/=""/' ${S}/aclocal-flags
+}
+
+ALLOW_EMPTY_${PN} = "1"
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"