aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagna.gianfranco@gmail.com>2018-04-29 20:02:06 +0200
committerArmin Kuster <akuster808@gmail.com>2018-05-17 08:32:26 -0700
commit12e8c3ea698905e2ed0edd9b7f351a497a1bd68d (patch)
tree6f65c7ba707ad2cf338bc1a99d70ecfe89f2d3b1 /meta-networking/recipes-support
parenta10bca9b090cdfd81c99f772e61c72ebd134ca45 (diff)
downloadmeta-openembedded-contrib-12e8c3ea698905e2ed0edd9b7f351a497a1bd68d.tar.gz
cpprest: add new recipe based on Debian packaging
The patches were imported from the Debian repository (https://salsa.debian.org/debian/casablanca) as of commit id 5b58637016a569a5d54714bd151a800028f77532 Signed-off-by: Gianfranco Costamagna <locutusofborg@debian.org> Signed-off-by: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com> Co-developed-by: Cristiano Prato <cristiano.prato@cnhind.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-networking/recipes-support')
-rw-r--r--meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch59
-rw-r--r--meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb17
2 files changed, 76 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch b/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch
new file mode 100644
index 0000000000..56fd704ad7
--- /dev/null
+++ b/meta-networking/recipes-support/cpprest/cpprest-2.10.2/fix-cmake-install.patch
@@ -0,0 +1,59 @@
+Description: install cmake files into /usr/lib/cmake/cpprestsdk
+Author: Gianfranco Costamagna <locutusofborg@debian.org>
+Upstream-Status: https://github.com/Microsoft/cpprestsdk/pull/737
+Forwarded: https://github.com/Microsoft/cpprestsdk/pull/737
+Last-Update: 2018-04-19
+
+Index: cpprest/CMakeLists.txt
+===================================================================
+--- cpprest.orig/CMakeLists.txt
++++ cpprest/CMakeLists.txt
+@@ -18,7 +18,6 @@
+ set(WERROR ON CACHE BOOL "Treat Warnings as Errors.")
+ set(CPPREST_EXCLUDE_WEBSOCKETS OFF CACHE BOOL "Exclude websockets functionality.")
+ set(CPPREST_EXCLUDE_COMPRESSION OFF CACHE BOOL "Exclude compression functionality.")
+-set(CPPREST_EXPORT_DIR lib/cpprestsdk CACHE STRING "Directory to install CMake config files.")
+ set(CPPREST_INSTALL_HEADERS ON CACHE BOOL "Install header files.")
+ set(CPPREST_INSTALL ON CACHE BOOL "Add install commands.")
+
+@@ -63,6 +62,9 @@
+ include(cmake/cpprest_find_openssl.cmake)
+ include(cmake/cpprest_find_websocketpp.cmake)
+ include(CheckIncludeFiles)
++if(UNIX)
++include(GNUInstallDirs)
++endif(UNIX)
+
+ find_package(Threads REQUIRED)
+ if(THREADS_HAVE_PTHREAD_ARG)
+Index: cpprest/src/CMakeLists.txt
+===================================================================
+--- cpprest.orig/src/CMakeLists.txt
++++ cpprest/src/CMakeLists.txt
+@@ -250,21 +250,21 @@
+ install(
+ TARGETS ${CPPREST_TARGETS}
+ EXPORT cpprestsdk-targets
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib
+- ARCHIVE DESTINATION lib
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ )
+
+ configure_file(../cmake/cpprestsdk-config.in.cmake "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake" @ONLY)
+
+ install(
+ FILES "${CMAKE_CURRENT_BINARY_DIR}/cpprestsdk-config.cmake"
+- DESTINATION ${CPPREST_EXPORT_DIR}
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
+ )
+ install(
+ EXPORT cpprestsdk-targets
+ FILE cpprestsdk-targets.cmake
+ NAMESPACE cpprestsdk::
+- DESTINATION ${CPPREST_EXPORT_DIR}
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake
+ )
+ endif()
diff --git a/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb b/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb
new file mode 100644
index 0000000000..2ba6fc66cc
--- /dev/null
+++ b/meta-networking/recipes-support/cpprest/cpprest_2.10.2.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
+SECTION = "libs/network"
+HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${S}/../license.txt;md5=a2e15b954769218ff912468eecd6a02f"
+DEPENDS = "openssl websocketpp zlib boost"
+
+SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master"
+
+SRC_URI += "file://fix-cmake-install.patch"
+
+# tag 2.10.2
+SRCREV= "fea848e2a77563cf2a6f28f8eab396fd6e787fbf"
+
+S = "${WORKDIR}/git/Release"
+
+inherit cmake