aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2014-03-20 15:44:17 +0800
committerJoe MacDonald <joe.macdonald@windriver.com>2014-03-27 15:41:12 -0400
commit6226023a2ee16d1c0897e6565815710a3734a17d (patch)
tree68e65088213b4baf10d735aca723e5de95b635a6 /meta-networking
parentc1d420a3b65538f80601411f85295db8f4cb30ab (diff)
downloadmeta-openembedded-contrib-6226023a2ee16d1c0897e6565815710a3734a17d.tar.gz
sethdlc : add recipe
* sethdlc: get/set Linux HDLC packet radio modem driver port information * sethdlc is a program designed to set and/or report the configuration information associated with a soundcard radio modem port. This information includes the modem type, what I/O port, IRQ and DMA channel a particular modem port is using, and where to output a transmitter keying (PTT) signal. Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/sethdlc/sethdlc.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
new file mode 100644
index 0000000000..3a9692f86f
--- /dev/null
+++ b/meta-networking/recipes-connectivity/sethdlc/sethdlc.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "set Linux HDLC packet radio modem driver port information"
+HOMEPAGE = "https://www.kernel.org/pub/linux/utils/net/hdlc"
+LICENSE = "GPLv2 & GPLv2+ "
+LIC_FILES_CHKSUM = "file://Makefile;md5=19aada31930b2be84bf7138420d77263"
+
+
+SRC_URI = "https://www.kernel.org/pub/linux/utils/net/hdlc/${BPN}-1.18.tar.gz \
+"
+SRC_URI[md5sum] = "9016878156a5eadb06c0bae71cc5c9ab"
+SRC_URI[sha256sum] = "21b1e2e1cb0e288b0ec8fcfd9fed449914e0f8e6fc273706bd5b3d4f6ab6b04e"
+
+
+S = "${WORKDIR}/${BPN}-1.18"
+
+DEPENDS="virtual/kernel"
+
+EXTRA_OEMAKE="CROSS_COMPILE=${TARGET_PREFIX} CC='${CC} ${LDFLAGS}' \
+ KERNEL_DIR=${STAGING_KERNEL_DIR} "
+
+do_compile_prepend () {
+ oe_runmake clean
+}
+
+
+do_install() {
+ install -d ${D}/${bindir}
+ install sethdlc ${D}/${bindir}/
+}
+
+FILES_${PN} += "${bindir}/sethdlc"