aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2013-02-25 13:24:11 +0800
committerJoe MacDonald <joe.macdonald@windriver.com>2013-02-25 09:59:45 -0500
commita7c6fcebee7d9f86c356ea92de445d89e714ff62 (patch)
tree552a2914a92a8a96169cc8d1cdc996e3b7496b3a /meta-networking
parent65fa455ef0501ebe2b76a3cd9388a945ec74842a (diff)
downloadmeta-openembedded-contrib-a7c6fcebee7d9f86c356ea92de445d89e714ff62.tar.gz
ebtables: move ebtables-save to sbindir to avoid QA issue
Fix the QA issue: WARNING: QA Issue: ebtables: Found a reference to /usr/ in /path/to/tmp/work/x86_64-wrs-linux/ebtables-2.0.10-4-r1/packages-split/ebtables/sbin/ebtables-save WARNING: QA Issue: Shell scripts in base_bindir and base_sbindir should not reference anything in exec_prefix Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
index bca34c0c63..d6d803add4 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.10-4.bb
@@ -2,7 +2,7 @@ SUMMARY = "Utility for basic Ethernet frame filtering on a Linux bridge, MAC NAT
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=53b4a999993871a28ab1488fdbd2e73e"
SECTION = "console/network"
-PR = "r1"
+PR = "r2"
RDEPENDS_${PN} += "perl"
@@ -44,6 +44,11 @@ do_install () {
# Fix hardcoded paths in scripts
sed -i 's!/sbin/!${base_sbindir}/!g' ${D}/${sysconfdir}/init.d/ebtables
sed -i 's!/etc/!${sysconfdir}/!g' ${D}/${sysconfdir}/init.d/ebtables
+
+ # The script ebtables-save refernces perl in exec_prefix, so
+ # move it to sbindir to avoid QA issue
+ install -d ${D}/${sbindir}
+ mv ${D}/${base_sbindir}/ebtables-save ${D}/${sbindir}
}
CONFFILES_${PN} += "${sysconfdir}/default/ebtables"