aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-05-26 09:24:44 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-06-05 22:18:30 -0400
commit01ffc1f2b28b2202187f041664e0c5e18064774c (patch)
treebb57ba71eed0a4ac59bbb42019298e8694f71dee /meta-networking
parent77d9d68c131d386b37d6d33a4f1601c1ecf400c5 (diff)
downloadmeta-openembedded-contrib-01ffc1f2b28b2202187f041664e0c5e18064774c.tar.gz
mbedtls: upgrade to 1.3.10
1. PolarSSL is now rebranded as mbed TLS. 2. upgrade to include CVE-2015-1182 fix: http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2015-1182 Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb (renamed from meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb)10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb
index caa4cd3a99..d5c7afe04f 100644
--- a/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb
@@ -1,5 +1,5 @@
SUMMARY = "Lightweight crypto and SSL/TLS library"
-DESCRIPTION = "PolarSSL is a lean open source crypto library \
+DESCRIPTION = "mbedtls is a lean open source crypto library \
for providing SSL and TLS support in your programs. It offers \
an intuitive API and documented header files, so you can actually \
understand what the code does. It features: \
@@ -23,13 +23,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "libdevel"
-SRC_URI = "https://polarssl.org/download/polarssl-${PV}-gpl.tgz"
+SRC_URI = "https://tls.mbed.org/download/mbedtls-${PV}-gpl.tgz"
-SRC_URI[md5sum] = "d1a2b4f21727e888f143414d2e3144e6"
-SRC_URI[sha256sum] = "318171db41335cacbb5b0047c94f1faf91442ab70a223b5223436703c9406ff1"
+SRC_URI[md5sum] = "19ebbc96feceb430ad958dfe89cb633f"
+SRC_URI[sha256sum] = "746fd88e0c6623691fc56c4eed52e40a57b2da0ac80f6dd8995094aa6adb407e"
DEPENDS = "openssl"
RDEPENDS_${PN} += "libcrypto"
+PROVIDES += "polarssl"
+RPROVIDES_${PN} = "polarssl"
EXTRA_OECMAKE = "-DUSE_SHARED_POLARSSL_LIBRARY=on -DLIB_INSTALL_DIR=${baselib}"
inherit cmake