aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-05-08 17:52:58 -0700
committerJoe MacDonald <joe_macdonald@mentor.com>2015-05-13 11:57:48 -0400
commit8da812fbb68a3ecfd7c950e087e97a6ca55fe394 (patch)
tree08b397751ef61424ed864f85ec863c96db5823ee /meta-networking
parent53d55216c8c721d3b66ec8f968737bf081def870 (diff)
downloadmeta-openembedded-contrib-8da812fbb68a3ecfd7c950e087e97a6ca55fe394.tar.gz
ntp: control refclock driver support via PACKAGECONFIG
The default configuration of ntp includes a large number of reference clock drivers. Provide a PACKAGECONFIG to allow control over whether or not these refclock drivers are built. Leave enabled by default. http://doc.ntp.org/4.2.8/refclock.html Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb b/meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb
index 693bdbbf04..811ec2e1cc 100644
--- a/meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb
+++ b/meta-networking/recipes-support/ntp/ntp_4.2.8p2.bb
@@ -8,7 +8,7 @@ SECTION = "console/network"
LICENSE = "NTP"
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=f41fedb22dffefcbfafecc85b0f79cfa"
-DEPENDS = "pps-tools libevent"
+DEPENDS = "libevent"
SRC_URI = "http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-${PV}.tar.gz \
file://ntp-4.2.4_p6-nano.patch \
@@ -45,7 +45,7 @@ USERADD_PARAM_${PN} = "--system --home-dir ${NTP_USER_HOME} \
--shell /bin/false --user-group ntp"
# NB: debug is default-enabled by NTP; keep it default-enabled here.
-PACKAGECONFIG ??= "cap debug"
+PACKAGECONFIG ??= "cap debug refclocks"
PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
--with-openssl-incdir=${STAGING_INCDIR} \
--with-crypto, \
@@ -53,6 +53,7 @@ PACKAGECONFIG[openssl] = "--with-openssl-libdir=${STAGING_LIBDIR} \
openssl"
PACKAGECONFIG[cap] = "--enable-linuxcaps,--disable-linuxcaps,libcap"
PACKAGECONFIG[readline] = "--with-lineeditlibs,--without-lineeditlibs,readline"
+PACKAGECONFIG[refclocks] = "--enable-all-clocks,--disable-all-clocks,pps-tools"
PACKAGECONFIG[debug] = "--enable-debugging,--disable-debugging"
do_install_append() {