aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-06-23 20:10:56 -0700
committerJoe MacDonald <joe.macdonald@windriver.com>2013-06-28 13:00:07 -0400
commit17bd75d60f42bfe3a10f299ace5432e2c97037d4 (patch)
tree62cc1abc8916b93dce54d28f2844592722fb7a7d /meta-networking
parent7e13ec6e239c1e010be86b56e2a2c3d5495bbe8f (diff)
downloadmeta-openembedded-contrib-17bd75d60f42bfe3a10f299ace5432e2c97037d4.tar.gz
netcat-openbsd: Update to 1.105
Add the missing dependency on libbsd it was not building otherwise. libbsd recipes for OE-Core has been ported please wait until they are applied | netcat.c:99:24: fatal error: bsd/stdlib.h: No such file or directory | #include <bsd/stdlib.h> | ^ | compilation terminated. | make: *** [netcat.o] Error 1 | make: *** Waiting for unfinished jobs.... | socks.c:41:32: fatal error: bsd/readpassphrase.h: No such file or directory | #include <bsd/readpassphrase.h> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb31
-rw-r--r--meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb32
2 files changed, 31 insertions, 32 deletions
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
new file mode 100644
index 0000000000..8f6cc546ff
--- /dev/null
+++ b/meta-networking/recipes-support/netcat/netcat-openbsd_1.105.bb
@@ -0,0 +1,31 @@
+require netcat.inc
+DESCRIPTION = "OpenBSD Netcat"
+HOMEPAGE = "http://ftp.debian.org"
+LICENSE = "BSD-3-Clause"
+
+DEPENDS += "glib-2.0 libbsd"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_${PV}.orig.tar.gz;name=netcat \
+ ${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_${PV}-7.debian.tar.gz;name=netcat-patch"
+
+SRC_URI[netcat.md5sum] = "7e67b22f1ad41a1b7effbb59ff28fca1"
+SRC_URI[netcat.sha256sum] = "40653fe66c1516876b61b07e093d826e2a5463c5d994f1b7e6ce328f3edb211e"
+SRC_URI[netcat-patch.md5sum] = "e914f8eb7eda5c75c679dd77787ac76b"
+SRC_URI[netcat-patch.sha256sum] = "eee759327ffea293e81d0dde67921b7fcfcad279ffd7a2c9d037bbc8f882b363"
+
+S = "${WORKDIR}/${BPN}-${PV}"
+
+do_configure[noexec] = "1"
+
+do_compile() {
+ cd ${S}
+ while read line; do patch -p1 < ${WORKDIR}/debian/patches/$line; done < ${WORKDIR}/debian/patches/series
+ pkgrel=4
+ oe_runmake CFLAGS="$CFLAGS -DDEBIAN_VERSION=\"\\\"${pkgrel}\\\"\""
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${S}/nc ${D}${bindir}/nc.${BPN}
+}
+ALTERNATIVE_PRIORITY = "50"
diff --git a/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb b/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb
deleted file mode 100644
index 0a30de6a49..0000000000
--- a/meta-networking/recipes-support/netcat/netcat-openbsd_1.89.bb
+++ /dev/null
@@ -1,32 +0,0 @@
-require netcat.inc
-DESCRIPTION = "OpenBSD Netcat"
-HOMEPAGE = "http://ftp.debian.org"
-LICENSE = "BSD-3-Clause"
-PR = "r2"
-
-DEPENDS += "glib-2.0"
-
-SRC_URI = "${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_1.89.orig.tar.gz;name=netcat \
- ${DEBIAN_MIRROR}/main/n/netcat-openbsd/netcat-openbsd_1.89-4.diff.gz;name=netcat-patch"
-
-SRC_URI[netcat.md5sum] = "7238ce15aae43069e96ba7faf03f153e"
-SRC_URI[netcat.sha256sum] = "72e844dde8a2a7cba61971d493758dbea9ef0b164bccef15fd4a36490dc77f2b"
-SRC_URI[netcat-patch.md5sum] = "00c65aa22243b76998174c733cbb64cc"
-SRC_URI[netcat-patch.sha256sum] = "d5b6b2bd9788114bdcfbb71acad0263720b4fdc41529e287adf451b8610f84f1"
-
-S = "${WORKDIR}/${BPN}-${PV}.orig"
-
-do_configure[noexec] = "1"
-
-do_compile() {
- cd ${S}
- while read line; do patch -p1 <debian/patches/$line; done <debian/patches/series
- pkgrel=4
- oe_runmake CFLAGS="$CFLAGS -DDEBIAN_VERSION=\"\\\"${pkgrel}\\\"\""
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 755 ${S}/nc ${D}${bindir}/nc.${BPN}
-}
-ALTERNATIVE_PRIORITY = "50"