aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorJugurtha BELKALEM <jugurtha.belkalem@smile.fr>2020-08-28 09:10:59 +0200
committerKhem Raj <raj.khem@gmail.com>2020-08-28 17:16:57 -0700
commita100cce1fcaa53f7f888ae11a95227d66ff1034d (patch)
tree3096313cd3f12138b7f6033823bf5b5013e284d6 /meta-networking
parent0a27b0840f57d64cab091c9a0681582832d72c2d (diff)
downloadmeta-openembedded-contrib-a100cce1fcaa53f7f888ae11a95227d66ff1034d.tar.gz
recipe/ettercap : new ettercap recipe
Ettercap is a comprehensive suite for man in the middle attacks. It features sniffing of live connections, content filtering on the fly and many other interesting tricks. It supports active and passive dissection of many protocols and includes many features for network and host analysis. To test ettercap : $ ettercap -T -i eth0 # Text mode or $ ettercap -C -i eth0 # console based mode Signed-off-by: Jugurtha BELKALEM <jugurtha.belkalem@smile.fr> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb b/meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb
new file mode 100644
index 0000000000..c641c265e2
--- /dev/null
+++ b/meta-networking/recipes-support/ettercap/ettercap_0.8.3.1.bb
@@ -0,0 +1,42 @@
+SUMMARY = "A suite for man in the middle attacks"
+HOMEPAGE = "https://github.com/Ettercap/ettercap"
+LICENSE = "GPL-2.0+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+inherit cmake
+
+DEPENDS += "ethtool \
+ geoip \
+ librepo \
+ libnet \
+ libpcap \
+ ncurses \
+ openssl \
+ zlib \
+ bison-native \
+ flex-native \
+ "
+
+RDEPENDS_${PN} += "bash ethtool libgcc"
+
+SRC_URI = "gitsm://github.com/Ettercap/ettercap"
+
+SRCREV = "7281fbddb7da7478beb1d21e3cb105fff3778b31"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE = " \
+ -DCMAKE_SKIP_RPATH=TRUE \
+ -DBUNDLED_LIBS=ON \
+ -DENABLE_IPV6=ON \
+ -DENABLE_GTK=OFF \
+"
+
+# Replaces default encoding set (ISO-8859-1) with UTF-8 in ettercap
+# configuration file installed by the package.
+# It ensures that all characters are properly decoded and avoids
+# any fatal errors while running in text mode (-T).
+do_install_append() {
+ sed -i 's@utf8_encoding.*@utf8_encoding = "UTF-8"@g' \
+ ${D}/etc/ettercap/etter.conf
+}