aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2018-08-28 10:27:48 +0800
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commit0b18276ac9155daf1e9075f2341078a9cc33a37d (patch)
treedcbb09ac26b5cd4c9b9cb92ddabaa2283a02a701 /meta-networking
parent196a373fb498e188378a147dd2332e9a06514d1c (diff)
downloadmeta-openembedded-contrib-0b18276ac9155daf1e9075f2341078a9cc33a37d.tar.gz
drbd-utils: fix usrmerge install path
Install the files under folder /usr/lib/drbd to instead of /lib/drbd and also /usr/lib/udev to instead of /lib/udev/ when usrmerge enabled to fix below issue: | WARNING: drbd-utils-9.5.0-r0 do_package: QA Issue: drbd-utils: Files/directories were installed but not shipped in any package: /lib/drbd/drbdsetup-84 /lib/drbd/drbdadm-83 /lib/drbd/drbdsetup-83 /lib/drbd/drbdadm-84 /lib/drbd/drbd | Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_insta. | drbd-utils: 5 installed and not shipped files. [installed-vs-shipped] | ERROR: QA Issue: drbd-utils-dbg package is not obeying usrmerge distro feature. /lib should be relocated to /usr. [usrmerge] Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb b/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb
index 0e3f952c9b..bd1e8576f3 100644
--- a/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb
+++ b/meta-networking/recipes-support/drbd/drbd-utils_9.5.0.bb
@@ -33,9 +33,20 @@ EXTRA_OECONF = " \
--with-distro debian \
--with-initscripttype=both \
--with-systemdunitdir=${systemd_unitdir}/system \
- --without-manual\
+ --without-manual \
"
+do_configure_prepend() {
+ # move the the file under folder /lib/drbd/ to /usr/lib/drbd when usrmerge enabled
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', 'true', 'false', d)}; then
+ for m_file in `find ${S} -name 'Makefile.in'`; do
+ sed -i -e "s;\$(DESTDIR)\/lib\/drbd;\$(DESTDIR)\${nonarch_libdir}\/drbd;g" $m_file
+ done
+ # move the the file under folder /lib/udev/ to /usr/lib/udev when usrmerge enabled
+ sed -i -e "s;default_udevdir=/lib/udev;default_udevdir=\${prefix}/lib/udev;g" ${S}/configure.ac
+ fi
+
+}
do_install_append() {
# don't install empty /var/lock to avoid conflict with base-files
rm -rf ${D}${localstatedir}/lock