aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-07-28 15:55:11 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-08-06 15:44:10 -0400
commit96b36e69759740ae9e902d71c3ac0bc93c89ba38 (patch)
treed498651b42eb14dc1f675001f6024b9afa4c75e0 /meta-networking
parenteee640df1a0dc28ec68c842fdaecc41ec69c087f (diff)
downloadmeta-openembedded-contrib-96b36e69759740ae9e902d71c3ac0bc93c89ba38.tar.gz
net-snmp: fix mib representation of timeout values
Fix mib representation of timeout values,correct conversion factor from microseconds to centiseconds. Signed-off-by: Wenlin Kang <wenlin.kang@windriver.com> Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-5.7.2-fix-mib-timeout-values.patch56
-rw-r--r--meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.1.bb1
2 files changed, 57 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-5.7.2-fix-mib-timeout-values.patch b/meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-5.7.2-fix-mib-timeout-values.patch
new file mode 100644
index 0000000000..324d1c05ca
--- /dev/null
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp/net-snmp-5.7.2-fix-mib-timeout-values.patch
@@ -0,0 +1,56 @@
+net-snmp: fix mib representation of timeout values
+
+The patch comes from the follow three commits on upstream:
+78dac6e37943d1ad99841898806ea60b0eede636
+390303059fbd98b1ee7621ddd4ad4c11d100fff9
+96302af7fc3108c208227432f0f0b75f3e7b906d
+
+The first commit:
+Fix bug number #a2478: fix mib representation of timeout values.
+The second commit:
+Reverts 78dac6e37943d1ad99841898806ea60b0eede636 and resolve a2478
+in a way that avoids truncating
+The third commit:
+Corrects conversion factor from microseconds to centiseconds.
+
+Upstream-Status: Backport
+
+Signed-off-by: Per Hallsmark <per.hallsmark@windriver.com>
+Signed-off-by: Wenlin Kang <wenlin.kang@windriver.com>
+
+diff -uarN net-snmp-5.7.2-org/agent/mibgroup/notification/snmpNotifyTable.c net-snmp-5.7.2/agent/mibgroup/notification/snmpNotifyTable.c
+--- net-snmp-5.7.2-org/agent/mibgroup/notification/snmpNotifyTable.c 2015-04-09 15:24:18.393570318 +0800
++++ net-snmp-5.7.2/agent/mibgroup/notification/snmpNotifyTable.c 2015-04-09 15:25:23.547569858 +0800
+@@ -331,7 +331,7 @@
+ ptr->tAddressLen = t->remote_length;
+ ptr->tAddress = t->remote;
+
+- ptr->timeout = ss->timeout / 1000;
++ ptr->timeout = ss->timeout / 10000;
+ ptr->retryCount = ss->retries;
+ SNMP_FREE(ptr->tagList);
+ ptr->tagList = strdup(ptr->name);
+diff -uarN net-snmp-5.7.2-org/agent/mibgroup/target/snmpTargetAddrEntry.h net-snmp-5.7.2/agent/mibgroup/target/snmpTargetAddrEntry.h
+--- net-snmp-5.7.2-org/agent/mibgroup/target/snmpTargetAddrEntry.h 2015-04-09 15:24:18.593570085 +0800
++++ net-snmp-5.7.2/agent/mibgroup/target/snmpTargetAddrEntry.h 2015-04-09 15:26:41.250570178 +0800
+@@ -51,7 +51,7 @@
+ int tDomainLen;
+ unsigned char *tAddress;
+ size_t tAddressLen;
+- int timeout;
++ int timeout; /* Timeout in centiseconds */
+ int retryCount;
+ char *tagList;
+ char *params;
+diff -uarN net-snmp-5.7.2-org/agent/mibgroup/target/target.c net-snmp-5.7.2/agent/mibgroup/target/target.c
+--- net-snmp-5.7.2-org/agent/mibgroup/target/target.c 2015-04-09 15:24:18.592569768 +0800
++++ net-snmp-5.7.2/agent/mibgroup/target/target.c 2015-04-09 15:25:52.586569961 +0800
+@@ -240,7 +240,7 @@
+ }
+ #endif
+ memset(&thissess, 0, sizeof(thissess));
+- thissess.timeout = (targaddrs->timeout) * 1000;
++ thissess.timeout = (targaddrs->timeout) * 10000;
+ thissess.retries = targaddrs->retryCount;
+ DEBUGMSGTL(("target_sessions",
+ "timeout: %d -> %ld\n",
diff --git a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.1.bb b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.1.bb
index 2d9d9740f1..464473e2ab 100644
--- a/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.1.bb
+++ b/meta-networking/recipes-protocols/net-snmp/net-snmp_5.7.2.1.bb
@@ -22,6 +22,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/net-snmp/net-snmp-${PV}.zip \
file://run-ptest \
file://0001-Fix-CVE-2014-2285.patch \
file://dont-return-incompletely-parsed-varbinds.patch \
+ file://net-snmp-5.7.2-fix-mib-timeout-values.patch \
"
SRC_URI[md5sum] = "a2c83518648b0f2a5d378625e45c0e18"