aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorZhu Yanjun <yanjun.zhu@windriver.com>2015-08-13 08:38:32 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2015-09-11 10:27:37 -0400
commitd3eaede791c121147f1b99db01facd2080019993 (patch)
tree82d5aed2efe9bd78107bd358c201c57c80e776a5 /meta-networking
parentd36e2d1066f50036080f978583a58fe79ecfac54 (diff)
downloadmeta-openembedded-contrib-d3eaede791c121147f1b99db01facd2080019993.tar.gz
ypbind-mt: add status command for initscript
Add the "status" command in initscript to check the status of ypbind. remove ypbind-yocto.init as ypbind.init, which is the initscript, make its name similar to other recipes Signed-off-by: Zhu Yanjun <yanjun.zhu@windriver.com> Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/nis/files/ypbind.init (renamed from meta-networking/recipes-support/nis/files/ypbind-yocto.init)7
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_1.38.bb4
-rw-r--r--meta-networking/recipes-support/nis/ypbind-mt_2.2.bb4
3 files changed, 11 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/nis/files/ypbind-yocto.init b/meta-networking/recipes-support/nis/files/ypbind.init
index 2c50d12e63..244dc78bca 100644
--- a/meta-networking/recipes-support/nis/files/ypbind-yocto.init
+++ b/meta-networking/recipes-support/nis/files/ypbind.init
@@ -21,6 +21,9 @@
# the NIS binding information.
### END INIT INFO
+# Need to use status function
+. /etc/init.d/functions
+
YPBIND_BIN=/usr/sbin/ypbind
pidfile=/var/run/ypbind.pid
@@ -92,6 +95,10 @@ case "$1" in
echo -n "Reload service ypbind"
start-stop-daemon --stop --quiet --signal 1 --pidfile $pidfile
;;
+ status)
+ echo -n "Checking for ypbind: "
+ status $YPBIND_BIN
+ ;;
*)
echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload|probe}"
exit 1
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
index d25ef5c754..5702cd6a5f 100644
--- a/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
+++ b/meta-networking/recipes-support/nis/ypbind-mt_1.38.bb
@@ -26,7 +26,7 @@ DEPENDS = " \
PROVIDES += "ypbind"
SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
- file://ypbind-yocto.init \
+ file://ypbind.init \
file://ypbind.service \
"
SRC_URI[md5sum] = "094088c0e282fa7f3b3dd6cc51d0a4e1"
@@ -44,7 +44,7 @@ do_install_append () {
install -d ${D}${sysconfdir}/init.d
install -d ${D}${sysconfdir}/rcS.d
- install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind
+ install -m 0755 ${WORKDIR}/ypbind.init ${D}${sysconfdir}/init.d/ypbind
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system
diff --git a/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb b/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
index 6a9262acab..cee5880f7a 100644
--- a/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
+++ b/meta-networking/recipes-support/nis/ypbind-mt_2.2.bb
@@ -21,7 +21,7 @@ PROVIDES += "ypbind"
PNBLACKLIST[ypbind-mt] ?= "BROKEN: Depends on broken yp-tools"
SRC_URI = "http://www.linux-nis.org/download/ypbind-mt/${BP}.tar.bz2 \
- file://ypbind-yocto.init \
+ file://ypbind.init \
file://ypbind.service \
"
SRC_URI[md5sum] = "54e2040d8266ae7d302d081ca310c8a8"
@@ -41,7 +41,7 @@ do_install_append () {
install -d ${D}${sysconfdir}/init.d
install -d ${D}${sysconfdir}/rcS.d
- install -m 0755 ${WORKDIR}/ypbind-yocto.init ${D}${sysconfdir}/init.d/ypbind
+ install -m 0755 ${WORKDIR}/ypbind.init ${D}${sysconfdir}/init.d/ypbind
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/ypbind.service ${D}${systemd_unitdir}/system