aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorAws Ismail <aws.ismail@windriver.com>2013-02-14 16:51:05 -0500
committerJoe MacDonald <joe.macdonald@windriver.com>2013-02-14 22:46:38 -0500
commitf67ed326aa40fff4d264d4723008d7bc43e0fb47 (patch)
tree4b2bb8972c742c051793e46f773e76efd1437cc7 /meta-networking
parent61911b23099c2658186179504ded318c987b5276 (diff)
downloadmeta-openembedded-contrib-f67ed326aa40fff4d264d4723008d7bc43e0fb47.tar.gz
traceroute: resolve multilib issues
Make recipe changes to enable successfull building when multilib is being used. Signed-off-by: Aws Ismail <aws.ismail@windriver.com> Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb b/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb
index 6eca7310a7..f52314003b 100644
--- a/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb
+++ b/meta-networking/recipes-support/traceroute/traceroute_2.0.18.bb
@@ -11,6 +11,8 @@ LICENSE = "GPL-2.0 LGPL-2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff"
+PR = "r1"
+
inherit update-alternatives
SRC_URI = "${SOURCEFORGE_MIRROR}/traceroute/traceroute/traceroute-2.0.18/traceroute-2.0.18.tar.gz \
@@ -26,14 +28,14 @@ do_compile() {
do_install() {
install -d ${D}${bindir}
- install -m755 ${PN}/${PN} ${D}${bindir}
+ install -m755 ${BPN}/${BPN} ${D}${bindir}
install -m755 wrappers/tcptraceroute ${D}${bindir}
install -d ${D}${mandir}
- install -p -m644 ${PN}/${PN}.8 ${D}${mandir}
- ln -s ${PN}.8 ${D}${mandir}/${PN}6.8
- ln -s ${PN}.8 ${D}${mandir}/tcptraceroute.8
+ install -p -m644 ${BPN}/${BPN}.8 ${D}${mandir}
+ ln -s ${BPN}.8 ${D}${mandir}/${BPN}6.8
+ ln -s ${BPN}.8 ${D}${mandir}/tcptraceroute.8
}