aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/fio/fio_3.7.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2018-07-20 03:02:28 -0700
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:14:22 -0700
commitbe7cdd94fd089d525f9741b35ae5350023de14de (patch)
tree623d5a48418aaa08bc2e5c794cfc33fd825e31bb /meta-oe/recipes-benchmark/fio/fio_3.7.bb
parentaf574eed885a42146458e3a5e3fd83a172b69fa9 (diff)
downloadmeta-openembedded-contrib-be7cdd94fd089d525f9741b35ae5350023de14de.tar.gz
fio: Upgrade to 3.7
* Licence-Update: Address update in COPYING * Add patch 0001-update-the-interpreter-paths.patch and add python and bash to RDEPENDS_${PN} to fix below QA issues: ERROR: fio-3.7-r0 do_package_qa: QA Issue: /usr/bin/fiologparser.py contained in package fio requires /usr/bin/python2.7, but no providers found in RDEPENDS_fio? [file-rdeps] ERROR: fio-3.7-r0 do_package_qa: QA Issue: /usr/bin/genfio contained in package fio requires /usr/bin/bash, but no providers found in RDEPENDS_fio? [file-rdeps] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark/fio/fio_3.7.bb')
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.7.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.7.bb b/meta-oe/recipes-benchmark/fio/fio_3.7.bb
new file mode 100644
index 0000000000..410e27b937
--- /dev/null
+++ b/meta-oe/recipes-benchmark/fio/fio_3.7.bb
@@ -0,0 +1,44 @@
+SUMMARY = "Filesystem and hardware benchmark and stress tool"
+DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
+stress/hardware verification. It has support for a number of I/O engines, \
+I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
+and much more. It can work on block devices as well as files. fio accepts \
+job descriptions in a simple-to-understand text format. Several example job \
+files are included. fio displays all sorts of I/O performance information."
+HOMEPAGE = "http://freecode.com/projects/fio"
+SECTION = "console/tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "libaio zlib"
+RDEPENDS_${PN} = "python bash"
+
+PACKAGECONFIG_NUMA = "numa"
+# ARM does not currently support NUMA
+PACKAGECONFIG_NUMA_arm = ""
+
+PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
+PACKAGECONFIG[numa] = ",--disable-numa,numactl"
+
+# rev for v3.7
+SRCREV = "c397ab3aac3d4ed1660d9cd4d820f31a4375306e"
+SRC_URI = "git://git.kernel.dk/fio.git \
+ file://0001-update-the-interpreter-paths.patch \
+"
+
+S = "${WORKDIR}/git"
+
+# avoids build breaks when using no-static-libs.inc
+DISABLE_STATIC = ""
+
+EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
+
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
+ install -d ${D}/${docdir}/${PN}
+ cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
+}