aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-08-08 11:39:55 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:57 +0200
commit98c0577972fe6843c8b81d3751b197b4dbd62d22 (patch)
tree132c77886030e695826529b3c10e544f91e993f0 /meta-oe/recipes-benchmark
parentc29c7ed7642c9e58a8e46f24a3d29e9dfed7da5a (diff)
downloadmeta-openembedded-contrib-98c0577972fe6843c8b81d3751b197b4dbd62d22.tar.gz
glmark2: Fix gcc 6 deprecated declaration error
Replace auto_ptr with unique_ptr. Upstream-Status: Pending Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch61
-rw-r--r--meta-oe/recipes-benchmark/glmark2/glmark2_git.bb3
2 files changed, 63 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch b/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch
new file mode 100644
index 0000000000..7a25de7908
--- /dev/null
+++ b/meta-oe/recipes-benchmark/glmark2/files/Fix-deprecated-declarations.patch
@@ -0,0 +1,61 @@
+Index: git/src/image-reader.cpp
+===================================================================
+--- git.orig/src/image-reader.cpp 2016-07-29 16:17:51.000000000 -0500
++++ git/src/image-reader.cpp 2016-07-29 16:18:43.000000000 -0500
+@@ -120,7 +120,7 @@
+
+ Log::debug("Reading PNG file %s\n", filename.c_str());
+
+- const std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
++ const std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
+ if (!(*is_ptr)) {
+ Log::error("Cannot open file %s!\n", filename.c_str());
+ return false;
+Index: git/src/libmatrix/shader-source.cc
+===================================================================
+--- git.orig/src/libmatrix/shader-source.cc 2016-07-29 16:18:14.000000000 -0500
++++ git/src/libmatrix/shader-source.cc 2016-07-29 16:18:43.000000000 -0500
+@@ -34,7 +34,7 @@
+ bool
+ ShaderSource::load_file(const std::string& filename, std::string& str)
+ {
+- std::auto_ptr<std::istream> is_ptr(Util::get_resource(filename));
++ std::unique_ptr<std::istream> is_ptr(Util::get_resource(filename));
+ std::istream& inputFile(*is_ptr);
+
+ if (!inputFile)
+Index: git/src/model.cpp
+===================================================================
+--- git.orig/src/model.cpp 2016-07-29 16:18:00.000000000 -0500
++++ git/src/model.cpp 2016-07-29 16:18:43.000000000 -0500
+@@ -361,7 +361,7 @@
+
+ Log::debug("Loading model from 3ds file '%s'\n", filename.c_str());
+
+- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
++ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
+ std::istream& input_file(*input_file_ptr);
+
+ if (!input_file) {
+@@ -681,7 +681,7 @@
+ {
+ Log::debug("Loading model from obj file '%s'\n", filename.c_str());
+
+- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
++ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
+ std::istream& inputFile(*input_file_ptr);
+ if (!inputFile)
+ {
+Index: git/src/scene-jellyfish.cpp
+===================================================================
+--- git.orig/src/scene-jellyfish.cpp 2016-07-29 16:18:08.000000000 -0500
++++ git/src/scene-jellyfish.cpp 2016-07-29 16:18:43.000000000 -0500
+@@ -272,7 +272,7 @@
+ {
+ Log::debug("Loading model from file '%s'\n", filename.c_str());
+
+- const std::auto_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
++ const std::unique_ptr<std::istream> input_file_ptr(Util::get_resource(filename));
+ std::istream& inputFile(*input_file_ptr);
+ if (!inputFile)
+ {
diff --git a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
index 18267e96f7..3a1c2e21aa 100644
--- a/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
+++ b/meta-oe/recipes-benchmark/glmark2/glmark2_git.bb
@@ -15,7 +15,8 @@ PV = "2014.03+${SRCPV}"
SRC_URI = "git://github.com/glmark2/glmark2.git;protocol=https \
file://build-Check-packages-to-be-used-by-the-enabled-flavo.patch \
file://0001-Fix-wl_surface-should-be-destoryed-after-the-wl_wind.patch \
- file://Fix-configure-for-sqrt-check.patch"
+ file://Fix-configure-for-sqrt-check.patch \
+ file://Fix-deprecated-declarations.patch"
SRCREV = "fa71af2dfab711fac87b9504b6fc9862f44bf72a"
S = "${WORKDIR}/git"