aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2016-07-26 13:34:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 11:01:02 +0200
commitd98b1a3f91712731c93d20e31db57af230e3b464 (patch)
tree56514dc4035c543d2d8ef7568c8a4315159631ed /meta-oe/recipes-benchmark
parenta720b93af53f31476c169d222cb47669ffce5dea (diff)
downloadmeta-openembedded-contrib-d98b1a3f91712731c93d20e31db57af230e3b464.tar.gz
sysbench: add new recipe
The project used to be hosted on Sourceforge, then Launchpad, and it moved to Github. The last stable release (0.4.12) cannot be found on Sourceforge anymore, and is not available (as tarball) on github. So using the tarball from Launchpad instead. We can move to github when the next release happens (which will be the first one from github). Tested with and without mysql, with and without aio. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-benchmark')
-rw-r--r--meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
new file mode 100644
index 0000000000..3c6954855f
--- /dev/null
+++ b/meta-oe/recipes-benchmark/sysbench/sysbench_0.4.12.bb
@@ -0,0 +1,26 @@
+SUMMARY = "System performance benchmark"
+HOMEPAGE = "http://github.com/akopytov/sysbench"
+SECTION = "console/tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+inherit autotools
+
+# The project has moved from Sourceforge to Launchpad, to Github. Use the source tarball from
+# Launchpad until the next release is available from Github.
+SRC_URI = "https://launchpad.net/ubuntu/+archive/primary/+files/${BPN}_${PV}.orig.tar.gz"
+
+SRC_URI[md5sum] = "3a6d54fdd3fe002328e4458206392b9d"
+SRC_URI[sha256sum] = "83fa7464193e012c91254e595a89894d8e35b4a38324b52a5974777e3823ea9e"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)}"
+PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
+PACKAGECONFIG[aio] = "--enable-aio,--disable-aio,libaio,"
+PACKAGECONFIG[mysql] = "--with-mysql \
+ --with-mysql-includes=${STAGING_INCDIR}/mysql \
+ --with-mysql-libs=${STAGING_LIBDIR}, \
+ --without-mysql,mysql5"
+
+do_configure_prepend() {
+ touch ${S}/NEWS ${S}/AUTHORS
+}