aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb')
-rw-r--r--meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb44
1 files changed, 22 insertions, 22 deletions
diff --git a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
index 3a2da3edc7..095a77c1c0 100644
--- a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
+++ b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf"
HOMEPAGE = "http://www.gammu.org/"
SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}/${PV}/${PN}-${PV}.tar.bz2 \
- file://gammurc \
- file://gammu-smsdrc \
- "
+ file://gammurc \
+ file://gammu-smsdrc \
+"
SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9"
SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3"
@@ -16,34 +16,34 @@ SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797
inherit distutils cmake gettext
do_install_append() {
- # these files seem to only be used by symbian and trigger QA warnings
- rm -rf ${D}/usr/share/gammu
- #install default configuration files
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc
- install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc
+ # these files seem to only be used by symbian and trigger QA warnings
+ rm -rf ${D}/usr/share/gammu
+ #install default configuration files
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc
+ install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc
}
EXTRA_OECONF = " \
- --enable-shared \
- --enable-backup \
- --enable-protection \
- "
+ --enable-shared \
+ --enable-backup \
+ --enable-protection \
+"
EXTRA_OECMAKE = " \
- -DWITH_CURL=OFF \
- -DWITH_BLUETOOTH=OFF \
- -DWITH_NOKIA_SUPPORT=OFF \
- -DWITH_IRDA=OFF \
- -DWITH_PYTHON=OFF \
- -DWITH_MySQL=ON \
- -DWITH_Postgres=OFF \
- "
+ -DWITH_CURL=OFF \
+ -DWITH_BLUETOOTH=OFF \
+ -DWITH_NOKIA_SUPPORT=OFF \
+ -DWITH_IRDA=OFF \
+ -DWITH_PYTHON=OFF \
+ -DWITH_MySQL=ON \
+ -DWITH_Postgres=OFF \
+"
PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \
- ${bindir}/gammu-detect ${sysconfdir}/gammurc"
+ ${bindir}/gammu-detect ${sysconfdir}/gammurc"
CONFFILES_${PN} = "${sysconfdir}/gammurc"
FILES_${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc"
CONFFILES_${PN}-smsd = "${sysconfdir}/gammu-smsdrc"