aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2012-11-26 18:10:15 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-11-27 12:45:56 +0100
commite919d827151e840d95fea189d8b56d046672510c (patch)
tree6c557ecee109e3a17a6d76571073effd24a6ac20 /meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
parent681ef5d05325c663ae0a223240e46740b08a8946 (diff)
downloadmeta-openembedded-contrib-e919d827151e840d95fea189d8b56d046672510c.tar.gz
gammu: import from OE-classic and upgrade to 1.32.0
- provide default configuration files for both gammu and gammu-smsd - enable MySQL support - enable libdbi support Signed-off-by: Eric BĂ©nard <eric@eukrea.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb')
-rw-r--r--meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
new file mode 100644
index 0000000000..3a2da3edc7
--- /dev/null
+++ b/meta-oe/recipes-connectivity/gammu/gammu_1.32.0.bb
@@ -0,0 +1,55 @@
+DESCRIPTION = "GNU All Mobile Managment Utilities"
+SECTION = "console/network"
+DEPENDS = "cmake-native virtual/libiconv libdbi mysql5"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a17cb0a873d252440acfdf9b3d0e7fbf"
+HOMEPAGE = "http://www.gammu.org/"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${PN}/${PV}/${PN}-${PV}.tar.bz2 \
+ file://gammurc \
+ file://gammu-smsdrc \
+ "
+
+SRC_URI[md5sum] = "8ea16c6b3cc48097a8e62311fe0e25b9"
+SRC_URI[sha256sum] = "de67caa102aa4c8fbed5300e5a0262e40411c4cc79f4379a8d34eed797968fc3"
+
+inherit distutils cmake gettext
+
+do_install_append() {
+ # these files seem to only be used by symbian and trigger QA warnings
+ rm -rf ${D}/usr/share/gammu
+ #install default configuration files
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/gammurc ${D}${sysconfdir}/gammurc
+ install -m 0644 ${WORKDIR}/gammu-smsdrc ${D}${sysconfdir}/gammu-smsdrc
+}
+
+EXTRA_OECONF = " \
+ --enable-shared \
+ --enable-backup \
+ --enable-protection \
+ "
+
+EXTRA_OECMAKE = " \
+ -DWITH_CURL=OFF \
+ -DWITH_BLUETOOTH=OFF \
+ -DWITH_NOKIA_SUPPORT=OFF \
+ -DWITH_IRDA=OFF \
+ -DWITH_PYTHON=OFF \
+ -DWITH_MySQL=ON \
+ -DWITH_Postgres=OFF \
+ "
+
+PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
+
+FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu \
+ ${bindir}/gammu-detect ${sysconfdir}/gammurc"
+CONFFILES_${PN} = "${sysconfdir}/gammurc"
+FILES_${PN}-smsd = "${bindir}/gammu-smsd* ${sysconfdir}/gammu-smsdrc"
+CONFFILES_${PN}-smsd = "${sysconfdir}/gammu-smsdrc"
+FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
+FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${PYTHON_SITEPACKAGES_DIR}/gammu/.debug"
+FILES_libgammu = "${libdir}/libGammu.so.*"
+FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
+FILES_python-${PN} = "${PYTHON_SITEPACKAGES_DIR}/gammu/*.??"
+