aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
index efecc64a0e..edd4615aa4 100644
--- a/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
+++ b/meta-oe/recipes-connectivity/gnuradio/gnuradio_git.bb
@@ -26,25 +26,25 @@ RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs \
python-compiler python-pkgutil python-pydoc python-mmap \
python-netclient python-difflib \
python-pprint python-numpy \
- "
+"
RDEPENDS_${PN}-grc = "python-pygtk python-lxml python-cheetah"
C_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
do_configure_prepend() {
- ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm
- echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt
- echo "SET_PROPERTY(TARGET generate_codebook APPEND PROPERTY IMPORTED_CONFIGURATIONS RELEASE)" >>${S}/gr-vocoder/lib/generate_codebook.txt
- echo 'SET_TARGET_PROPERTIES(generate_codebook PROPERTIES IMPORTED_LOCATION_RELEASE "${S}/gr-vocoder/lib/generate_codebook")' >>${S}/gr-vocoder/lib/generate_codebook.txt
+ ${BUILD_CC} ${S}/gr-vocoder/lib/codec2/generate_codebook.c -o ${S}/gr-vocoder/lib/generate_codebook -lm
+ echo "ADD_EXECUTABLE(generate_codebook IMPORTED)" >${S}/gr-vocoder/lib/generate_codebook.txt
+ echo "SET_PROPERTY(TARGET generate_codebook APPEND PROPERTY IMPORTED_CONFIGURATIONS RELEASE)" >>${S}/gr-vocoder/lib/generate_codebook.txt
+ echo 'SET_TARGET_PROPERTIES(generate_codebook PROPERTIES IMPORTED_LOCATION_RELEASE "${S}/gr-vocoder/lib/generate_codebook")' >>${S}/gr-vocoder/lib/generate_codebook.txt
}
do_compile_prepend() {
- cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2
+ cp ${S}/gr-vocoder/lib/codec2/defines.h ${OECMAKE_BUILDPATH}/gr-vocoder/lib/codec2
}
PACKAGES += " \
- ${PN}-examples \
- ${PN}-grc \
+ ${PN}-examples \
+ ${PN}-grc \
"
FILES_${PN}-grc = "${datadir}/gnuradio/grc"
@@ -57,7 +57,7 @@ FILES_${PN} += "${prefix}/etc/gnuradio/*"
FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/gnuradio/.debug \
${PYTHON_SITEPACKAGES_DIR}/gnuradio/*/.debug \
${datadir}/gnuradio/examples/*/.debug \
- "
+"
FILES_${PN}-examples = "${datadir}/gnuradio/examples"
PV = "3.6.4.1"
@@ -96,7 +96,7 @@ EXTRA_OEMAKE = "-C ${OECMAKE_BUILDPATH}"
# Only builds for machines with neon instructions. Problem is in upstream cmake.
python () {
- if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d):
- raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES")
+ if not oe.utils.contains ('TUNE_FEATURES', 'neon', True, False, d):
+ raise bb.parse.SkipPackage("'neon' not in TUNE_FEATURES")
}