aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-19 12:33:43 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-19 12:33:43 +0100
commit83429a16a98d4aeea5ce2f41b084c33fd1ec5326 (patch)
tree49608c16b1207d1bbf4668b4f71cd2acc75a1549 /meta-oe/recipes-connectivity
parent8c967075f04e10fc3ae83f442795548d2d6c4ce1 (diff)
downloadmeta-openembedded-contrib-83429a16a98d4aeea5ce2f41b084c33fd1ec5326.tar.gz
uhd: update to 3.3.1 to match kernel and FPGA firmware
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd.inc20
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd_git.bb4
2 files changed, 13 insertions, 11 deletions
diff --git a/meta-oe/recipes-connectivity/uhd/uhd.inc b/meta-oe/recipes-connectivity/uhd/uhd.inc
index b08d1a0662..466a19c8ad 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd.inc
+++ b/meta-oe/recipes-connectivity/uhd/uhd.inc
@@ -7,20 +7,22 @@ DEPENDS = "git-native python-cheetah-native boost libusb1 uhd-firmware orc-nativ
RDEPENDS_${PN} += "uhd-firmware"
PE = "1"
-INC_PR = "r0"
+INC_PR = "r1"
inherit cmake
-PACKAGES =+ "${PN}-tests ${PN}-examples"
+PACKAGES =+ "${PN}-tests ${PN}-examples ${PN}-e1xx"
-FILES_${PN} += "${libdir}/libuhd.so"
-FILES_${PN} += "${datadir}/uhd/utils/*"
+INSANE_SKIP_${PN} = "dev-so"
+
+FILES_${PN} += "${libdir}/libuhd.so \
+ ${datadir}/uhd/utils/*"
FILES_${PN}-tests += "${datadir}/uhd/tests/*"
-FILES_${PN}-dbg += "${datadir}/uhd/examples/.debug \
- ${datadir}/uhd/utils/.debug \
- ${datadir}/uhd/tests/.debug \
- ${datadir}/uhd/usrp_e_utils/.debug \
- "
+FILES_${PN}-e1xx += "${datadir}/uhd/usrp_e_utils/*"
+FILES_${PN}-dbg += "${datadir}/uhd/examples/.debug/* \
+" ${datadir}/uhd/utils/.debug/* \
+ ${datadir}/uhd/tests/.debug/* \
+ ${datadir}/uhd/usrp_e_utils/.debug/*"
FILES_${PN}-examples = "${datadir}/uhd/examples/*"
OECMAKE_BUILDPATH = "${S}/build"
diff --git a/meta-oe/recipes-connectivity/uhd/uhd_git.bb b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
index 329a39598b..cd9c554ff0 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd_git.bb
+++ b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
@@ -1,10 +1,10 @@
require uhd.inc
-PV = "3.2.1"
+PV = "3.3.1"
PR = "${INC_PR}.0"
SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;protocol=git \
file://0001-HACK-work-around-Wl-as-needed-problems.patch;striplevel=2"
S = "${WORKDIR}/git/host"
-SRCREV = "fc349d30507620baca935e75e68a9554b40d427c"
+SRCREV = "f8d66fcfb14062283cdb0d0cbe4f77e2964ceb82"