aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-07-01 07:23:21 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-07-08 10:35:57 +0200
commit830baf380ea86782a5a52fbe8762904840e05691 (patch)
tree3a6da23c5ef6f80540874e53478f5da3c3df297e /meta-oe/recipes-connectivity
parent8d0528448b9b79437cf04cd12b7a0dc282df3c48 (diff)
downloadmeta-openembedded-contrib-830baf380ea86782a5a52fbe8762904840e05691.tar.gz
uhd: Fix compile errors
uhd would fail with wrong scope for uint8_t type errors. Signed-off-by: Khem Raj <raj.khem@gmail.com> CC: Philip Balister <philip@balister.org> Acked-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch29
-rw-r--r--meta-oe/recipes-connectivity/uhd/uhd_git.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch b/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch
new file mode 100644
index 0000000000..8978ddcc44
--- /dev/null
+++ b/meta-oe/recipes-connectivity/uhd/uhd/0001-use-uint8_t-from-boost-namespace.patch
@@ -0,0 +1,29 @@
+From 317f6f08cedf005ce1f2d6f0d04cfb2659863423 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 30 Jun 2013 22:10:50 -0700
+Subject: [PATCH] use uint8_t from boost namespace
+
+Fixes errors like
+codec_ctrl.cpp:113:10: error: 'uint8_t' was not declared in this scope
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ host/lib/usrp/e100/codec_ctrl.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/host/lib/usrp/e100/codec_ctrl.cpp b/host/lib/usrp/e100/codec_ctrl.cpp
+index 13b3bc9..2c13176 100644
+--- a/host/lib/usrp/e100/codec_ctrl.cpp
++++ b/host/lib/usrp/e100/codec_ctrl.cpp
+@@ -110,7 +110,7 @@ e100_codec_ctrl_impl::e100_codec_ctrl_impl(spi_iface::sptr iface){
+ //_ad9862_regs.dis2 = ad9862_regs_t::DIS2_DIS; needed for transmit
+
+ //write the register settings to the codec
+- for (uint8_t addr = 0; addr <= 25; addr++){
++ for (boost::uint8_t addr = 0; addr <= 25; addr++){
+ this->send_reg(addr);
+ }
+
+--
+1.7.9.5
+
diff --git a/meta-oe/recipes-connectivity/uhd/uhd_git.bb b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
index 06d5effbdc..180fd27c7e 100644
--- a/meta-oe/recipes-connectivity/uhd/uhd_git.bb
+++ b/meta-oe/recipes-connectivity/uhd/uhd_git.bb
@@ -4,7 +4,8 @@ PV = "3.5.3"
PR = "${INC_PR}.0"
SRC_URI = "git://ettus.sourcerepo.com/ettus/uhd.git;branch=maint;protocol=git \
-"
+ file://0001-use-uint8_t-from-boost-namespace.patch;striplevel=2 \
+ "
S = "${WORKDIR}/git/host"
SRCREV = "f4c58120dc1e3674ee0228213f0f0011a0f80dcf"