aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 15:39:22 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-13 19:06:44 +0200
commit25a78e55e961197fd182afc8e21942bbbd8b4d59 (patch)
treef6fe164bc009248c476f98c350c1ab70297e90fe /meta-oe/recipes-connectivity
parentd78c5215b35b945b0543b62234d00ae041de41b9 (diff)
downloadmeta-openembedded-contrib-25a78e55e961197fd182afc8e21942bbbd8b4d59.tar.gz
abiword, fbreader, tvheadend, glmark2, libqmi, modemmanager, thrift, wvdial, wvstreams, dt, collectd, gtkmathview, tcsh, glcompbench, geos, libspatialite, geis, grail, opencv, openwbem, fwts: blacklist, fails to build with gcc-6 or glibc-2.24
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb3
-rw-r--r--meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb2
-rw-r--r--meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb2
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb2
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb3
5 files changed, 12 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb b/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb
index 7a15527f14..937fafc88f 100644
--- a/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb
+++ b/meta-oe/recipes-connectivity/libqmi/libqmi_1.12.6.bb
@@ -14,3 +14,6 @@ inherit autotools pkgconfig
SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BPN}-${PV}.tar.xz"
SRC_URI[md5sum] = "24c9eb300662ba6cff0152de89bd9ec0"
SRC_URI[sha256sum] = "0857bffece4e8ddfa7f721dd9ca63b4c78de345ac9ae2faebf04062cacba3780"
+
+# http://errors.yoctoproject.org/Errors/Details/68616/
+PNBLACKLIST[libqmi] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb
index a173e696ab..00b85ffd5c 100644
--- a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb
+++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.4.12.bb
@@ -17,6 +17,8 @@ SRC_URI[sha256sum] = "7ef5035375a953b285a742591df0a65fd442f4641ce4d8f4392a41d6d6
S = "${WORKDIR}/ModemManager-${PV}"
+PNBLACKLIST[modemmanager] ?= "Depends on broken libqmi"
+
PACKAGECONFIG ??= "mbim qmi polkit \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
"
diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
index b6b73ade5d..e1413b0d5c 100644
--- a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
+++ b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb
@@ -33,3 +33,5 @@ do_install_append () {
ln -sf thrift ${D}/${bindir}/thrift-compiler
}
+# http://errors.yoctoproject.org/Errors/Details/68622/
+PNBLACKLIST[thrift] ?= "BROKEN: fails to build with gcc-6"
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
index f7adf4c9f4..65617fa3be 100644
--- a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
@@ -28,3 +28,5 @@ do_configure() {
do_install() {
oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
}
+
+PNBLACKLIST[wvdial] ?= "Depends on broken wvstreams"
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
index 6199a2f7ec..8d864484ab 100644
--- a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
@@ -46,3 +46,6 @@ FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debu
FILES_${PN}-valgrind = "${libdir}/valgrind/wvstreams.supp"
RDEPENDS_${PN} += "perl"
+
+# http://errors.yoctoproject.org/Errors/Details/68614/
+PNBLACKLIST[wvstreams] ?= "BROKEN: fails to build with gcc-6"