aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-08-20 13:39:15 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:48:01 +0200
commitb0b6ae9cc54c8b06bdbc2944bb82cffd384dd6b3 (patch)
tree1549f684017a26dcb64b45491698596c0ba10d09 /meta-oe/recipes-connectivity
parent5c6046a5d13b19813597a7d9548833dc167ec0fd (diff)
downloadmeta-openembedded-contrib-b0b6ae9cc54c8b06bdbc2944bb82cffd384dd6b3.tar.gz
zeromq: upgrade to 4.1.3
4.1.3 has the dependence on libsodium, 4.1.3 asks pkgconfig bbclass to configure, add a target to build ptest, since the orignial check will build and run which is not suitable for cross-compile, and change the ptest installation directories Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/zeromq/zeromq_4.1.3.bb (renamed from meta-oe/recipes-connectivity/zeromq/zeromq_4.0.4.bb)14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta-oe/recipes-connectivity/zeromq/zeromq_4.0.4.bb b/meta-oe/recipes-connectivity/zeromq/zeromq_4.1.3.bb
index 80907fa7c0..5d0e2d5571 100644
--- a/meta-oe/recipes-connectivity/zeromq/zeromq_4.0.4.bb
+++ b/meta-oe/recipes-connectivity/zeromq/zeromq_4.1.3.bb
@@ -2,12 +2,13 @@ DESCRIPTION = "ZeroMQ looks like an embeddable networking library but acts like
HOMEPAGE = "http://www.zeromq.org"
LICENSE = "LGPLv3+"
LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=d5311495d952062e0e4fbba39cbf3de1"
+DEPENDS = "libsodium"
SRC_URI = "http://download.zeromq.org/zeromq-${PV}.tar.gz \
file://run-ptest \
"
-SRC_URI[md5sum] = "f3c3defbb5ef6cc000ca65e529fdab3b"
-SRC_URI[sha256sum] = "1ef71d46e94f33e27dd5a1661ed626cd39be4d2d6967792a275040e34457d399"
+SRC_URI[md5sum] = "d0824317348cfb44b8692e19cc73dc3a"
+SRC_URI[sha256sum] = "61b31c830db377777e417235a24d3660a4bcc3f40d303ee58df082fcd68bf411"
S = "${WORKDIR}/zeromq-${PV}"
@@ -16,9 +17,14 @@ S = "${WORKDIR}/zeromq-${PV}"
#CFLAGS_append += "-O0"
#CXXFLAGS_append += "-O0"
-inherit autotools ptest
+inherit autotools ptest pkgconfig
+
+do_compile_ptest () {
+ echo 'buildtest-TESTS: $(check_PROGRAMS)' >> ${B}/Makefile
+ oe_runmake buildtest-TESTS
+}
do_install_ptest () {
install -d ${D}${PTEST_PATH}/tests
- install -m 0755 ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests
+ install -m 0755 ${B}/.libs/test_* ${D}${PTEST_PATH}/tests
}