aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorChunrong Guo <B40290@freescale.com>2013-08-30 10:21:24 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-10 22:43:13 +0200
commit8ef842b8ad2ede706110afe83171876122651ec6 (patch)
treea29804efe612892e8c96ef67e725e5495c64ebac /meta-oe/recipes-connectivity
parente0eaa29f0208bf32ce33e1a50ad9a1f39f7b6c27 (diff)
downloadmeta-openembedded-contrib-8ef842b8ad2ede706110afe83171876122651ec6.tar.gz
daq: add recipe
*The dump DAQ test the various inline mode features *snort depends daq Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/daq/daq_2.0.1.bb16
-rw-r--r--meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch29
2 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/daq/daq_2.0.1.bb b/meta-oe/recipes-connectivity/daq/daq_2.0.1.bb
new file mode 100644
index 0000000000..4c1be443da
--- /dev/null
+++ b/meta-oe/recipes-connectivity/daq/daq_2.0.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The dump DAQ test the various inline mode features "
+HOMEPAGE = "http://www.snort.org"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f9ce51a65dd738dc1ae631d8b21c40e0"
+
+PARALLEL_MAKE = ""
+
+DEPENDS = "libpcap libpcre "
+
+SRC_URI = "http://fossies.org/linux/misc/daq-${PV}.tar.gz \
+ file://disable-run-test-program-while-cross-compiling.patch "
+
+SRC_URI[md5sum] = "044aa3663d44580d005293eeb8ccf175"
+SRC_URI[sha256sum] = "ebba87c2ec76ac65d2980934423b0597909caead3a86ce5d1ba1ea6ce518ec6d"
+
+inherit autotools
diff --git a/meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch b/meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch
new file mode 100644
index 0000000000..12a6cba600
--- /dev/null
+++ b/meta-oe/recipes-connectivity/daq/files/disable-run-test-program-while-cross-compiling.patch
@@ -0,0 +1,29 @@
+Upstream-Status:Inappropriate [embedded specific]
+
+fix the below error:
+configure: error: cannot run test program while cross compiling
+
+Signed-off-by: Chunrong Guo <B40290@freescale.com>
+
+--- a/m4/sf.m4old 2013-08-30 04:08:18.768409680 -0500
++++ b/m4/sf.m4 2013-08-30 04:09:24.591367890 -0500
+@@ -135,19 +135,6 @@
+ exit 1
+ fi
+ AC_MSG_CHECKING([for libpcap version >= $1])
+- AC_RUN_IFELSE(
+- [AC_LANG_PROGRAM(
+- [[
+- #include <pcap.h>
+- #include <string.h>
+- extern char pcap_version[];
+- ]],
+- [[
+- if (strcmp(pcap_version, $1) < 0)
+- return 1;
+- ]])],
+- [libpcap_version_1x="yes"],
+- [libpcap_version_1x="no"])
+ if test "x$libpcap_version_1x" = "xno"; then
+ AC_MSG_RESULT(no)
+ echo