aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-09-04 14:11:58 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-09-05 10:05:06 +0200
commit21a4be0e36bb1ee6c3c469c83a623c5d9a45257a (patch)
treebe14375786b4756c8c9d62020cc99a8b2da808fa /meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
parentf3dbc97b44a5dd2588eb0c6ed7e3ce1b1e997847 (diff)
downloadmeta-openembedded-contrib-21a4be0e36bb1ee6c3c469c83a623c5d9a45257a.tar.gz
task*: rename to packagegroup to match oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/packagegroups/packagegroup-boot.bb')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-boot.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
new file mode 100644
index 0000000000..ac31118346
--- /dev/null
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "Basic task to get a device booting"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r57"
+
+inherit packagegroup
+
+# packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
+#
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+#
+# those ones can be set in machine config to supply packages needed to get machine booting
+#
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
+MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
+
+# Make sure we build the kernel
+DEPENDS = "virtual/kernel"
+
+#
+# minimal set of packages - needed to boot
+#
+RDEPENDS_${PN} = "\
+ base-files \
+ base-passwd \
+ busybox \
+ netbase \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \
+ ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
+ "
+
+RRECOMMENDS_${PN} = "\
+ kernel \
+ ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
+ "