aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2013-05-29 03:09:30 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-12 16:23:22 +0200
commita3ccaa1009bcbb852f2a95c5982df2af14b1b7ad (patch)
tree233bc7824b68d7ba95ff1887ac12295cba88d57a /meta-oe/recipes-core
parentb57465fc8c023b798b713766ca7d093a6752186b (diff)
downloadmeta-openembedded-contrib-a3ccaa1009bcbb852f2a95c5982df2af14b1b7ad.tar.gz
llvm2.9: allow parallel native make
* fix parallel build Doing a parallel build may result in the following: *** No rule to make target `native/bin/tblgen', needed by `include/llvm/Intrinsics.gen.tmp' Avoid this by building tblgen first before building the rest of llvm. Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/llvm/llvm.inc5
-rw-r--r--meta-oe/recipes-core/llvm/llvm2.9_2.9.bb2
2 files changed, 5 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm.inc b/meta-oe/recipes-core/llvm/llvm.inc
index 62304959f0..27f8c84b05 100644
--- a/meta-oe/recipes-core/llvm/llvm.inc
+++ b/meta-oe/recipes-core/llvm/llvm.inc
@@ -103,6 +103,11 @@ FILES_${PN}-dev = " \
${libdir}/llvm${LLVM_RELEASE}/*.a \
"
+base_do_compile_prepend() {
+ # Avoid *** No rule to make target `native/bin/tblgen', needed by `include/llvm/Intrinsics.gen.tmp'
+ oe_runmake tblgen
+}
+
do_install() {
# Install into a private directory to be able to reorganize the files.
diff --git a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
index 2b46162e92..ee7c3a3cfb 100644
--- a/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
+++ b/meta-oe/recipes-core/llvm/llvm2.9_2.9.bb
@@ -15,8 +15,6 @@ ARM_INSTRUCTION_SET = "arm"
SRC_URI_append_libc-uclibc = " file://arm_fenv_uclibc.patch "
-PARALLEL_MAKE_virtclass-native = ""
-
LLVM_EXTRA_ARCH = "X86;"
LLVM_EXTRA_ARCH_x86 = ""
LLVM_EXTRA_ARCH_x86-64 = ""