aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2014-04-29 14:16:33 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-05-03 20:47:03 +0200
commitd47fe965e1a30caa220e51f239fc78ae488ea15b (patch)
tree1587d0319ce84a1444c6d90c648ba823ce158c3b /meta-oe/recipes-core
parent5ab2ad3981b8c454e903cbbe62e8cce17c356293 (diff)
downloadmeta-openembedded-contrib-d47fe965e1a30caa220e51f239fc78ae488ea15b.tar.gz
llvm3: Fix build when S != B
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/llvm/llvm3.inc8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/llvm/llvm3.inc b/meta-oe/recipes-core/llvm/llvm3.inc
index 798d4a2458..a5bd896c60 100644
--- a/meta-oe/recipes-core/llvm/llvm3.inc
+++ b/meta-oe/recipes-core/llvm/llvm3.inc
@@ -21,14 +21,14 @@ EXTRA_OEMAKE += "REQUIRES_RTTI=1 VERBOSE=1"
do_configure_prepend() {
# Remove RPATHs
- sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' Makefile.rules
+ sed -i 's:$(RPATH) -Wl,$(\(ToolDir\|LibDir\|ExmplDir\))::g' ${S}/Makefile.rules
# Drop "svn" suffix from version string
- sed -i 's/${PV}svn/${PV}/g' configure
+ sed -i 's/${PV}svn/${PV}/g' ${S}/configure
# Fix paths in llvm-config
- sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" tools/llvm-config/llvm-config.cpp
- sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" tools/llvm-config/llvm-config.cpp
+ sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp
+ sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" ${S}/tools/llvm-config/llvm-config.cpp
# Fails to build unless using separate directory from source
mkdir -p ${LLVM_BUILD_DIR}