aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-03 18:03:14 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:33:04 -0800
commit0e5dfce3b695128f396555bd69ebb9413e842a19 (patch)
treef768d9434c75d022d6a2e639c9ff77502ae08970 /meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb
parent01e54eb2fa5fb3e528781f51c85e79eb8c9b74d1 (diff)
downloadmeta-openembedded-contrib-0e5dfce3b695128f396555bd69ebb9413e842a19.tar.gz
jsoncpp: update to version 1.8.4
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb')
-rw-r--r--meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb b/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb
new file mode 100644
index 0000000000..88e3320324
--- /dev/null
+++ b/meta-oe/recipes-devtools/jsoncpp/jsoncpp_1.8.4.bb
@@ -0,0 +1,21 @@
+SUMMARY = "JSON C++ lib used to read and write json file."
+DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \
+ and writer in C++. JSON (JavaScript Object Notation) is a \
+ lightweight data-interchange format. It is easy for humans to \
+ read and write. It is easy for machines to parse and generate."
+
+HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
+
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b"
+
+SRCREV = "ddabf50f72cf369bf652a95c4d9fe31a1865a781"
+SRC_URI = "git://github.com/open-source-parsers/jsoncpp"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DJSONCPP_WITH_TESTS=OFF"