aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/acpica/acpitests_20140114.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2014-01-17 13:06:14 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-22 12:22:49 +0100
commite2cfe2076006540ee6f82db3404a040bf3e19868 (patch)
tree2bf3d3e4b7828f007f7bab94b780292d0644ca90 /meta-oe/recipes-extended/acpica/acpitests_20140114.bb
parentef03b5a1180e89afae8ab80ec826c27905d88e52 (diff)
downloadmeta-openembedded-contrib-e2cfe2076006540ee6f82db3404a040bf3e19868.tar.gz
acpitests: add 20140114 release
Before upstream split the source tarballs this was part of acpica-tools in various distros. Let's follow upstream naming in OE. This only builds and packages 'aapits', no other tests or helper scripts. Fixing the 'aapitsrun' helper script is left for a followup patch. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/acpica/acpitests_20140114.bb')
-rw-r--r--meta-oe/recipes-extended/acpica/acpitests_20140114.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/acpica/acpitests_20140114.bb b/meta-oe/recipes-extended/acpica/acpitests_20140114.bb
new file mode 100644
index 0000000000..d84ac64a66
--- /dev/null
+++ b/meta-oe/recipes-extended/acpica/acpitests_20140114.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Test suite used to validate ACPICA."
+HOMEPAGE = "http://www.acpica.org/"
+
+LICENSE = "Intel"
+LIC_FILES_CHKSUM = "file://tests/aapits/atexec.c;beginline=1;endline=115;md5=e92bcdfcd01d117d1bda3e814bb2030a"
+
+DEPENDS = "bison flex"
+
+SRC_URI = "https://acpica.org/sites/acpica/files/acpitests-unix-${PV}.tar.gz \
+ https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \
+ file://0001-Fixup-aapits-build.patch \
+ "
+SRC_URI[md5sum] = "c72b61e092d2b25726dfff6e455116c9"
+SRC_URI[sha256sum] = "368f69296edef5138fd33affa2d50bdcdd1dfd2f6919ba782f8ecf03971a3a2c"
+
+S = "${WORKDIR}/acpitests-unix-${PV}"
+
+EXTRA_OEMAKE = "CC=${TARGET_PREFIX}gcc 'OPT_CFLAGS=-Wall'"
+
+# The Makefiles expect a specific layout
+do_compile() {
+ cp -af ${WORKDIR}/acpica-unix2-${PV}/source ${S}
+ cd tests/aapits
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m0755 tests/aapits/bin/aapits ${D}${bindir}
+}
+
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"