aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:57:00 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-11 11:43:10 +0100
commit58b0cdd1d6239e8f2125426db8297fde4c002342 (patch)
treec7b9856cc3af52940fdc5d093e027167c5378223 /meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
parent851a064b53dca3b14dd33eaaaca9573b1a36bf0e (diff)
downloadmeta-openembedded-contrib-jansa/krogoth.tar.gz
cmpi-bindings: fix build with python 3jansa/krogoth
This recipe seemed to have a floating dependency on Python 3, so let's make it fixed. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb')
-rw-r--r--meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
index a2747c3508..63fc849d28 100644
--- a/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
+++ b/meta-oe/recipes-extended/cmpi-bindings/cmpi-bindings_git.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "http://github.com/kkaempf/cmpi-bindings"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=b19ee058d2d5f69af45da98051d91064"
SECTION = "Development/Libraries"
-DEPENDS = "swig-native python sblim-cmpi-devel"
+DEPENDS = "swig-native python3 sblim-cmpi-devel"
SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=http \
file://cmpi-bindings-0.4.17-no-ruby-perl.patch \
@@ -13,12 +13,13 @@ SRC_URI = "git://github.com/kkaempf/cmpi-bindings.git;protocol=http \
file://0001-Modify-cmakelist.patch \
file://0001-Fix-error.patch \
file://0001-fix-the-build-error-when-python-3.0.patch \
+ file://0001-Add-PYTHON_ABI-suffix-to-the-python-library-name.patch \
"
SRCREV = "62f60e065aa1b901f826e4f530c0573ae32d065e"
S = "${WORKDIR}/git"
-inherit cmake pythonnative
+inherit cmake python3native
EXTRA_OECMAKE = "-DLIB='${baselib}' \
-DPYTHON_INCLUDE_PATH=${STAGING_INCDIR}/python${PYTHON_BASEVERSION}"