aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/gnuplot/gnuplot/0004-Add-configure-option-to-find-qt5-native-tools.patch
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-03-18 20:08:32 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-21 18:45:10 -0700
commit2a3bc6d719068bd71b7c6daae200fce2c0958ead (patch)
treea2a793e0196231feda561f3d865ba70ba52f8a5b /meta-oe/recipes-extended/gnuplot/gnuplot/0004-Add-configure-option-to-find-qt5-native-tools.patch
parenta26ac6adece18a575abb371b2b6d153fdb777048 (diff)
downloadmeta-openembedded-contrib-2a3bc6d719068bd71b7c6daae200fce2c0958ead.tar.gz
gnuplot: update 5.0.5 -> 5.2.2 and rework
* merge gnuplot.inc to recipe - nothing else requres gnuplot.inc * add native build required to build all kind of docs * patches were far from applying so they were reworked: * subdirs.patch -> 0001...-0002... * lua-loadlibs-configure-in-fix.patch: Test with lua in PACKAGECONFIG without issues * qt4 packageconfig was replaced by qt5 (build tested) * make desktop file work Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/gnuplot/gnuplot/0004-Add-configure-option-to-find-qt5-native-tools.patch')
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot/0004-Add-configure-option-to-find-qt5-native-tools.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot/0004-Add-configure-option-to-find-qt5-native-tools.patch b/meta-oe/recipes-extended/gnuplot/gnuplot/0004-Add-configure-option-to-find-qt5-native-tools.patch
new file mode 100644
index 0000000000..7ed9e761f2
--- /dev/null
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot/0004-Add-configure-option-to-find-qt5-native-tools.patch
@@ -0,0 +1,42 @@
+From 577e21622475fa29fd471149cf2380c53fdbfcbd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Tue, 6 Mar 2018 22:26:48 +0100
+Subject: [PATCH] Add configure option to find qt5 native tools
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Pkg-config checks for target locations. With these qt5 tools as uic/moc..
+cannot be used.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index cdd831a..fdd192b 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1133,11 +1133,15 @@ if test "${enable_qt}" = yes ; then
+ else
+ try_qt4=yes
+ fi
++ AC_ARG_WITH(qt5nativesysroot,
++ AC_HELP_STRING([--with-qt5nativesysroot=PATH], [prepend path - for native qt5 tools]),
++ [QT5NATIVESYSROOT="$withval"], [QT5NATIVESYSROOT=""])
++
+ if test "x${with_qt}" != "xqt4"; then
+ PKG_CHECK_MODULES_NOFAIL(QT, [Qt5Core Qt5Gui Qt5Network Qt5Svg Qt5PrintSupport])
+ if test $pkg_failed = no; then
+ try_qt4=no
+- QT5LOC=`$PKG_CONFIG --variable=host_bins Qt5Core`
++ QT5LOC=${QT5NATIVESYSROOT}`$PKG_CONFIG --variable=host_bins Qt5Core`
+ if test "x${QT5LOC}" != "x"; then
+ UIC=${QT5LOC}/uic
+ MOC=${QT5LOC}/moc
+--
+2.14.3
+