aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/liblogging
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-08-17 17:51:17 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:58:18 +0200
commitaa89c5154a816ff26017f1abbfdbd41827c0569c (patch)
tree70b5b5fb78216823193363552299962d39b4fa2b /meta-oe/recipes-extended/liblogging
parentce3897e61d2063940a7fe635c35401ed10a6a568 (diff)
downloadmeta-openembedded-contrib-aa89c5154a816ff26017f1abbfdbd41827c0569c.tar.gz
liblogging: add the recipe
rsyslog 7.6.1 needs it Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/liblogging')
-rw-r--r--meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb b/meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb
new file mode 100644
index 0000000000..3488b19a30
--- /dev/null
+++ b/meta-oe/recipes-extended/liblogging/liblogging_1.0.5.bb
@@ -0,0 +1,23 @@
+SUMMARY = "An easy to use logging library"
+DESCRIPTION = " \
+liblogging (the upstream project) is a collection of several components. \
+Namely: stdlog, journalemu, rfc3195. \
+The stdlog component of liblogging can be viewed as an enhanced version of \
+the syslog(3) API. It retains the easy semantics, but makes the API more \
+sophisticated "behind the scenes" with better support for multiple threads \
+and flexibility for different log destinations (e.g. syslog and systemd \
+journal)."
+SECTION = "libs"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=63fe03535d83726f5655072502bef1bc"
+SRC_URI = "http://download.rsyslog.com/${BPN}/${BPN}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "44b8ce2daa1bfb84c9feaf42f9925fd7"
+SRC_URI[sha256sum] = "310dc1691279b7a669d383581fe4b0babdc7bf75c9b54a24e51e60428624890b"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-man-pages"
+
+PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}"
+PACKAGECONFIG[systemd] = "--enable-journal, --disable-journal, systemd"