aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/snappy
diff options
context:
space:
mode:
authorHongzhi.Song <hongzhi.song@windriver.com>2018-07-29 18:47:43 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-02 02:12:15 -0700
commita79ca6831128ee99806f4f68a239d17ca6555d88 (patch)
tree2be2f6e268bd79f93b426d68f60b0bc39812ba18 /meta-oe/recipes-extended/snappy
parent371796ac31e405fb34e909ad4e3b236e9565c31e (diff)
downloadmeta-openembedded-contrib-a79ca6831128ee99806f4f68a239d17ca6555d88.tar.gz
snappy: add a new recipe
Snappy is a compression/decompression library. It does not aim for maximum compression, or compatibility with any other compression library; instead, it aims for very high speeds and reasonable compression. Signed-off-by: Hongzhi.Song <hongzhi.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/snappy')
-rw-r--r--meta-oe/recipes-extended/snappy/snappy_1.1.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/snappy/snappy_1.1.7.bb b/meta-oe/recipes-extended/snappy/snappy_1.1.7.bb
new file mode 100644
index 0000000000..6f1978a070
--- /dev/null
+++ b/meta-oe/recipes-extended/snappy/snappy_1.1.7.bb
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2014 Wind River Systems, Inc.
+# Released under the BSD-3-Clause license (see COPYING.BSD-3 for the terms)
+#
+SUMMARY = "A compression/decompression library"
+DESCRIPTION = "Snappy is a fast data compression and decompression library \
+It was designed to be very fast and stable, but not to achieve a high \
+compression ratio."
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c"
+
+SRC_URI = "https://src.fedoraproject.org/repo/pkgs/snappy/snappy-1.1.7.tar.gz/sha512/32046f532606ba545a4e4825c0c66a19be449f2ca2ff760a6fa170a3603731479a7deadb683546e5f8b5033414c50f4a9a29f6d23b7a41f047e566e69eca7caf/snappy-1.1.7.tar.gz"
+
+SRC_URI[md5sum] = "ee9086291c9ae8deb4dac5e0b85bf54a"
+SRC_URI[sha256sum] = "3dfa02e873ff51a11ee02b9ca391807f0c8ea0529a4924afa645fbf97163f9d4"
+
+inherit cmake pkgconfig
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo,"