aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/subsurface
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-15 18:40:36 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-15 18:40:36 +0200
commitde2f5c9c87cd413aa954fdeb459b502c27168bd9 (patch)
tree01111b52a04259da39d3b243a94362c59f3ea4e6 /meta-oe/recipes-extended/subsurface
parent3b592422e98a9eda79970807ace52aa372314200 (diff)
downloadmeta-openembedded-contrib-de2f5c9c87cd413aa954fdeb459b502c27168bd9.tar.gz
subsurface: inital add
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended/subsurface')
-rw-r--r--meta-oe/recipes-extended/subsurface/subsurface_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/subsurface/subsurface_git.bb b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
new file mode 100644
index 0000000000..b1a7e3ee19
--- /dev/null
+++ b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Subsurface is an open source dive log program."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0"
+
+inherit gtk-icon-cache
+
+PV = "1.0"
+SRCREV = "f2c61aefa762ce2ef7dea61886afeb23b0fe5eff"
+SRC_URI = "git://subsurface.hohndel.org/subsurface.git"
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "CC='${CC}' \
+ libdc-usr=${STAGING_INCDIR}/libdivecomputer/* \
+ LIBDIVECOMPUTERINCLUDES=${STAGING_INCDIR}/libdivecomputer \
+ LIBDIVECOMPUTERARCHIVE=${STAGING_LIBDIR}/libdivecomputer.a \
+ "
+
+do_install() {
+ install -d ${D}${datadir}/man/man1
+ oe_runmake install prefix=${D}${prefix}
+ rm ${D}${datadir}/icons/hicolor/icon-theme.cache
+}
+
+FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg"
+RRECOMMENDS_${PN}_append_libc-glibc = " eglibc-gconv-iso8859-15"
+