aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-01-28 15:50:13 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-12 19:33:24 +0100
commit37a841321dca1314c9844d8d4665b5ff1e28a40f (patch)
treefa18605b97edc9ae7517f0e06489e88e661f5b1e /meta-oe/recipes-extended
parent20a624928c030fa13d8b7d45b4f4d7e1ac624f60 (diff)
downloadmeta-openembedded-contrib-37a841321dca1314c9844d8d4665b5ff1e28a40f.tar.gz
recipes: add x11 to required DISTRO_FEATURES
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/dlm/dlm_4.0.2.bb2
-rw-r--r--meta-oe/recipes-extended/gnuplot/gnuplot.inc4
-rw-r--r--meta-oe/recipes-extended/sip/sip_4.16.4.bb4
-rw-r--r--meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb4
4 files changed, 10 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb b/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb
index 0de707ebad..560630c74b 100644
--- a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb
+++ b/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "file://README.license;md5=8f0bbcdd678df1bce9863492b6c8832d"
DEPENDS = "corosync systemd"
-inherit pkgconfig systemd
+inherit pkgconfig systemd distro_features_check
SYSTEMD_SERVICE_${PN} = "dlm.service"
SYSTEMD_AUTO_ENABLE = "enable"
diff --git a/meta-oe/recipes-extended/gnuplot/gnuplot.inc b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
index 6c27e6d8ab..69bc74b047 100644
--- a/meta-oe/recipes-extended/gnuplot/gnuplot.inc
+++ b/meta-oe/recipes-extended/gnuplot/gnuplot.inc
@@ -6,7 +6,9 @@ LICENSE = "gnuplot"
LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f"
DEPENDS = "virtual/libx11 gd readline"
-inherit autotools
+inherit autotools distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
acpaths = ""
diff --git a/meta-oe/recipes-extended/sip/sip_4.16.4.bb b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
index 2a2674f918..607ace69fa 100644
--- a/meta-oe/recipes-extended/sip/sip_4.16.4.bb
+++ b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
@@ -14,7 +14,9 @@ SRC_URI[sha256sum] = "ceda443fc5e129e67a067e2cd7b73ff037f8b10b50e407baa2b1d9f219
BBCLASSEXTEND = "native"
-inherit qmake2 python-dir pythonnative
+inherit qmake2 python-dir pythonnative distro_features_check
+# depends on qt4-x11-free
+REQUIRED_DISTRO_FEATURES = "x11"
EXTRA_QMAKEVARS_POST += "CONFIG=console"
diff --git a/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb b/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
index 90a0290e02..1d670a7d76 100644
--- a/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
+++ b/meta-oe/recipes-extended/t1lib/t1lib_5.1.2.bb
@@ -13,7 +13,9 @@ SRC_URI = "${DEBIAN_MIRROR}/main/t/t1lib/t1lib_${PV}.orig.tar.gz \
SRC_URI[md5sum] = "a5629b56b93134377718009df1435f3c"
SRC_URI[sha256sum] = "821328b5054f7890a0d0cd2f52825270705df3641dbd476d58d17e56ed957b59"
-inherit autotools-brokensep
+inherit autotools-brokensep distro_features_check
+# depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
# Fix GNU_HASH problem
TARGET_CC_ARCH += "${LDFLAGS}"