aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 13:49:59 +0000
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-28 14:32:06 +0000
commit3a30c562385cb3d9cd1b3043f6fe677a22024018 (patch)
tree66dc67f338ba316c25ca672950ef334e9e357386 /meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
parentd66c9a8b625f7b19f7b17e728dc82413399c2e19 (diff)
downloadmeta-openembedded-contrib-3a30c562385cb3d9cd1b3043f6fe677a22024018.tar.gz
Replace bb.data.* with d.*
Used sed expression given here: http://lists.linuxtogo.org/pipermail/openembedded-core/2011-November/012373.html Plus an additional expression for .expand. Full expression is: sed \ -e 's:bb.data.\(setVar([^,]*,[^,]*\), \([^ )]*\) *):\2.\1):g' \ -e 's:bb.data.\(setVarFlag([^,]*,[^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^, ]*\) *,\([^)]*\)):\2.\1,\3):g' \ -e 's:bb.data.\(getVarFlag([^,]*,[^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(getVar([^,]*\), \([^) ]*\) *):\2.\1):g' \ -e 's:bb.data.\(expand([^,]*\), \([^ )]*\) *):\2.\1):g' \ -i `grep -ril bb.data *` Some minor correction in systemd.bbclass was needed for some expressions that didn't quite match the regex in the desired way; additionally a few instances were manually changed. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb')
-rw-r--r--meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
index 8e842c48fe..3f6d7673ce 100644
--- a/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
+++ b/meta-oe/recipes-graphics/openbox/openbox_3.5.0.bb
@@ -23,8 +23,8 @@ PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome"
PACKAGES_DYNAMIC += "^${PN}-theme-.*"
python populate_packages_prepend() {
- theme_dir = bb.data.expand('${datadir}/themes/', d)
- theme_name = bb.data.expand('${PN}-theme-%s', d)
+ theme_dir = d.expand('${datadir}/themes/')
+ theme_name = d.expand('${PN}-theme-%s')
do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
}