aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.16.bb
diff options
context:
space:
mode:
authorJean-Francois Dagenais <dagenaisj@sonatest.com>2019-02-11 13:45:48 -0500
committerJean-Francois Dagenais <jeff.dagenais@gmail.com>2019-02-11 14:54:43 -0500
commit1752b6aa4e5e4ad7b0bd8b5fdf3c78b043da98a9 (patch)
treee29cb804f04503b4fbe622967c477087a14ee7b1 /meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.16.bb
parent876b48b5712c71dfa7b217e9cdb71989b3e0c147 (diff)
downloadmeta-openembedded-contrib-1752b6aa4e5e4ad7b0bd8b5fdf3c78b043da98a9.tar.gz
x11vnc: uprev to 0.9.16
Diffstat (limited to 'meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.16.bb')
-rw-r--r--meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.16.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.16.bb b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.16.bb
new file mode 100644
index 0000000000..794b2f048a
--- /dev/null
+++ b/meta-oe/recipes-graphics/x11vnc/x11vnc_0.9.16.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Exports your X session or FrameBuffer(fbdev) on-the-fly via VNC"
+HOMEPAGE = "http://www.karlrunge.com/x11vnc/"
+
+SECTION = "x11/utils"
+AUTHOR = "Karl Runge"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://src/x11vnc.h;endline=31;md5=e871a2ad004776794b616822dcab6314"
+
+SRC_URI = "https://github.com/LibVNC/x11vnc/archive/${PV}.tar.gz;downloadfilename=x11vnc-${PV}.tar.gz\
+ file://starting-fix.patch \
+"
+
+SRC_URI[md5sum] = "64172e8f896389ec963fff93415f0d93"
+SRC_URI[sha256sum] = "885e5b5f5f25eec6f9e4a1e8be3d0ac71a686331ee1cfb442dba391111bd32bd"
+
+DEPENDS = "\
+ jpeg \
+ libtasn1 \
+ libvncserver \
+ openssl \
+ p11-kit \
+ zlib \
+"
+
+inherit pkgconfig autotools distro_features_check
+
+ANY_OF_DISTRO_FEATURES = "x11 fbdev"
+
+PACKAGECONFIG ??= "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
+"
+
+PACKAGECONFIG[avahi] = "--with-avahi,--without-avahi,avahi"
+PACKAGECONFIG[xinerama] = "--with-xinerama,--without-xinerama,libxinerama"
+PACKAGECONFIG[x11] = "--with-x,--without-x, libxdamage libxext libxfixes libxrandr libxtst virtual/libx11"
+