aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/xserver-nodm-init
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-12-26 19:32:33 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-09 10:31:00 +0100
commit0265a98f7140cb4c43da7e19e25fef3c205c3c8f (patch)
tree03edb7176f575865d6692471769d819e5cfd1c9b /meta-oe/recipes-graphics/xserver-nodm-init
parent2292ac565c220f2112a07abd563c6a9ee34dc662 (diff)
downloadmeta-openembedded-contrib-0265a98f7140cb4c43da7e19e25fef3c205c3c8f.tar.gz
xserver-nodm-init: move systemd service to xserver-nodm-init-systemd
Move systemd service to xserver-nodm-init-systemd to be consistent with other packages. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'meta-oe/recipes-graphics/xserver-nodm-init')
-rw-r--r--meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb30
1 files changed, 14 insertions, 16 deletions
diff --git a/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb b/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
index 496b3428b8..2132eabb35 100644
--- a/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
+++ b/meta-oe/recipes-graphics/xserver-nodm-init/xserver-nodm-init_2.0.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "x11"
-PR = "r11"
+PR = "r12"
SRC_URI = "file://xserver-nodm \
file://xserver-nodm.service \
@@ -13,6 +13,15 @@ S = ${WORKDIR}
inherit allarch
+inherit update-rc.d systemd
+
+INITSCRIPT_NAME = "xserver-nodm"
+INITSCRIPT_PARAMS = "start 01 5 2 . stop 01 0 1 6 ."
+INITSCRIPT_PARAMS_shr = "start 90 5 2 . stop 90 0 1 6 ."
+
+SYSTEMD_PACKAGES = "${PN}-systemd"
+SYSTEMD_SERVICE_${PN}-systemd = "xserver-nodm.service"
+
do_install() {
install -d ${D}${sysconfdir}/init.d
install xserver-nodm ${D}${sysconfdir}/init.d
@@ -21,20 +30,9 @@ do_install() {
install -m 0644 xserver-nodm.service ${D}${base_libdir}/systemd/system/
}
-RDEPENDS_${PN} = "xserver-common (>= 1.30) xinit"
-FILES_${PN} += "${base_libdir}/systemd/system/"
-
-inherit update-rc.d
+PACKAGES += "${PN}-systemd"
-INITSCRIPT_NAME = "xserver-nodm"
-INITSCRIPT_PARAMS = "start 01 5 2 . stop 01 0 1 6 ."
-INITSCRIPT_PARAMS_shr = "start 90 5 2 . stop 90 0 1 6 ."
-
-pkg_postinst_${PN}_append () {
- if [ -e ${base_bindir}/systemctl ] ; then
- # can't do this offline
- [ "x$D" != "x" ] && exit 1
+RDEPENDS_${PN} = "xserver-common (>= 1.30) xinit"
- systemctl enable xserver-nodm.service
- fi
-}
+FILES_${PN}-systemd += "${base_libdir}/systemd/system/"
+RDEPENDS_${PN}-systemd += "xserver-common (>= 1.30) xinit"