aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/spidev-test/spidev-test.bb
diff options
context:
space:
mode:
authorArun Parameswaran <arun.parameswaran@broadcom.com>2020-02-14 11:44:20 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commit82eafcc41c11694474d8e7f6829d2d4c24842feb (patch)
treeb8064e3856d57ec28c33771ae16a83ed538cae4f /meta-oe/recipes-kernel/spidev-test/spidev-test.bb
parentabc2a8515ab94befa75813937a68e86579d2c32b (diff)
downloadmeta-openembedded-contrib-82eafcc41c11694474d8e7f6829d2d4c24842feb.tar.gz
spidev-test: Add initial version of recipe
Allows for testing SPI interface using spidev driver and is part of the kernel tools. Signed-off-by: Arun Parameswaran <arun.parameswaran@broadcom.com> Reviewed-by: Jonathan Richardson <jonathan.richardson@broadcom.com> Tested-by: Jonathan Richardson <jonathan.richardson@broadcom.com> Signed-off-by: Jonathan Richardson <jonathan.richardson@broadcom.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/spidev-test/spidev-test.bb')
-rw-r--r--meta-oe/recipes-kernel/spidev-test/spidev-test.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/spidev-test/spidev-test.bb b/meta-oe/recipes-kernel/spidev-test/spidev-test.bb
new file mode 100644
index 0000000000..6626302919
--- /dev/null
+++ b/meta-oe/recipes-kernel/spidev-test/spidev-test.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Test SPI devices"
+DESCRIPTION = "SPI testing utility using the spidev driver"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+PROVIDES = "virtual/spidev-test"
+
+inherit bash-completion kernelsrc kernel-arch
+
+do_populate_lic[depends] += "virtual/kernel:do_patch"
+
+EXTRA_OEMAKE = "-C ${S}/tools/spi O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+python do_package_prepend() {
+ d.setVar('PKGV', d.getVar("KERNEL_VERSION", True).split("-")[0])
+}
+
+B = "${WORKDIR}/${BPN}-${PV}"