aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/webm/libvpx_1.5.0.bb
diff options
context:
space:
mode:
authorChang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com>2016-03-04 10:58:19 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-07 13:02:18 +0100
commit907504c948bfae124f87cdfdfbcd32183f914d07 (patch)
treed085612e1a5c15db2c086c499197eac1ecf1b662 /meta-oe/recipes-multimedia/webm/libvpx_1.5.0.bb
parentdf7242fddb9048738c0cdfaf0c3c227bf78f3da7 (diff)
downloadmeta-openembedded-contrib-907504c948bfae124f87cdfdfbcd32183f914d07.tar.gz
libvpx: upgrade to version 1.5.0
This version had improved VP9 encoder and speeds up the encoding and decoding process. Signed-off-by: Chang Rebecca Swee Fun <rebecca.swee.fun.chang@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia/webm/libvpx_1.5.0.bb')
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx_1.5.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.5.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.5.0.bb
new file mode 100644
index 0000000000..648818e722
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.5.0.bb
@@ -0,0 +1,49 @@
+SUMMARY = "VPX multi-format codec"
+DESCRIPTION = "The BSD-licensed libvpx reference implementation provides en- and decoders for VP8 and VP9 bitstreams."
+HOMEPAGE = "http://www.webmproject.org/code/"
+BUGTRACKER = "http://code.google.com/p/webm/issues/list"
+SECTION = "libs/multimedia"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
+
+SRC_URI += "http://storage.googleapis.com/downloads.webmproject.org/releases/webm/${BP}.tar.bz2 \
+ file://libvpx-configure-support-blank-prefix.patch \
+ "
+SRC_URI[md5sum] = "49e59dd184caa255886683facea56fca"
+SRC_URI[sha256sum] = "306d67908625675f8e188d37a81fbfafdf5068b09d9aa52702b6fbe601c76797"
+
+# ffmpeg links with this and fails
+# sysroots/armv4t-oe-linux-gnueabi/usr/lib/libvpx.a(vpx_encoder.c.o)(.text+0xc4): unresolvable R_ARM_THM_CALL relocation against symbol `memcpy@@GLIBC_2.4'
+ARM_INSTRUCTION_SET = "arm"
+
+CFLAGS += "-fPIC"
+
+export CC
+export LD = "${CC}"
+
+VPXTARGET_armv5te = "armv5te-linux-gcc"
+VPXTARGET_armv6 = "armv6-linux-gcc"
+VPXTARGET_armv7a = "armv7-linux-gcc"
+VPXTARGET ?= "generic-gnu"
+
+CONFIGUREOPTS = " \
+ --target=${VPXTARGET} \
+ --enable-vp9 \
+ --enable-libs \
+ --disable-install-docs \
+ --disable-static \
+ --enable-shared \
+ --prefix=${prefix} \
+ --libdir=${libdir} \
+ --size-limit=16384x16384 \
+"
+
+do_configure() {
+ ${S}/configure ${CONFIGUREOPTS}
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+ chown -R root:root ${D}
+}