aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-navigation
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb4
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb30
-rw-r--r--meta-oe/recipes-navigation/navit/navit.inc54
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps_svn.bb4
-rw-r--r--meta-oe/recipes-navigation/orrery/orrery_2.7.bb4
5 files changed, 48 insertions, 48 deletions
diff --git a/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb b/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
index 62860b8688..ca1a01e840 100644
--- a/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
+++ b/meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb
@@ -15,9 +15,9 @@ inherit autotools pkgconfig perlnative gconf
PR = "r2"
do_configure_prepend() {
- if [ -f ${S}/configure.in ] ; then
+ if [ -f ${S}/configure.in ] ; then
mv ${S}/configure.in ${S}/configure.ac
- fi
+ fi
}
RRECOMMENDS_${PN} = "gpsd"
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
index 1228614790..99f019bd2e 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bb
@@ -10,14 +10,14 @@ EXTRANATIVEPATH += "chrpath-native"
PR = "r6"
SRC_URI = "http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz \
- file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
- file://0004-SConstruct-remove-rpath.patch \
- file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
- file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
- file://gpsd-default \
- file://gpsd \
- file://60-gpsd.rules \
- file://gpsd.service \
+ file://0002-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch \
+ file://0004-SConstruct-remove-rpath.patch \
+ file://0001-SConstruct-prefix-includepy-with-sysroot-and-drop-sy.patch \
+ file://0001-SConstruct-disable-html-and-man-docs-building-becaus.patch \
+ file://gpsd-default \
+ file://gpsd \
+ file://60-gpsd.rules \
+ file://gpsd.service \
"
SRC_URI[md5sum] = "52d9785eaf1a51298bb8900dbde88f98"
SRC_URI[sha256sum] = "7800c478ee9d7ca7a502b0f892828561b1fbf7bc69d9d38c447c82c3628302ac"
@@ -33,11 +33,11 @@ export STAGING_INCDIR
export STAGING_LIBDIR
EXTRA_OESCONS = " \
- sysroot=${STAGING_DIR_TARGET} \
- libQgpsmm='false' \
- debug='true' \
- strip='false' \
- systemd='${SYSTEMD_OESCONS}' \
+ sysroot=${STAGING_DIR_TARGET} \
+ libQgpsmm='false' \
+ debug='true' \
+ strip='false' \
+ systemd='${SYSTEMD_OESCONS}' \
"
# this cannot be used, because then chrpath is not found and only static lib is built
# target=${HOST_SYS}
@@ -88,11 +88,11 @@ do_install_append() {
}
pkg_postinst_${PN}-conf() {
- update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
+ update-alternatives --install ${sysconfdir}/default/gpsd gpsd-defaults ${sysconfdir}/default/gpsd.default 10
}
pkg_postrm_${PN}-conf() {
- update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
+ update-alternatives --remove gpsd-defaults ${sysconfdir}/default/gpsd.default
}
PACKAGES =+ "libgps libgpsd python-pygps-dbg python-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"
diff --git a/meta-oe/recipes-navigation/navit/navit.inc b/meta-oe/recipes-navigation/navit/navit.inc
index dc2370b63f..a90203a599 100644
--- a/meta-oe/recipes-navigation/navit/navit.inc
+++ b/meta-oe/recipes-navigation/navit/navit.inc
@@ -18,14 +18,14 @@ INC_PR = "r9"
inherit autotools gettext
EXTRA_OECONF += " \
- --disable-binding-python \
- --disable-samplemap \
- --enable-avoid-unaligned \
- --enable-graphics-qt-qpainter \
- --enable-gui-qml \
- --enable-svg2png-scaling-flag=32 \
- --disable-speech-speech-dispatcher \
- --enable-cache-size=20971520 \
+ --disable-binding-python \
+ --disable-samplemap \
+ --enable-avoid-unaligned \
+ --enable-graphics-qt-qpainter \
+ --enable-gui-qml \
+ --enable-svg2png-scaling-flag=32 \
+ --disable-speech-speech-dispatcher \
+ --enable-cache-size=20971520 \
"
# --enable-avoid-float \
@@ -38,19 +38,19 @@ PACKAGES =+ "${PN}-maptool ${PN}-config ${PN}-dbus ${PN}-speech-cmdline ${PN}-sp
EXTRA_AUTORECONF = " -I m4"
CONFFILES_${PN}-config += "${datadir}/navit/navit.default.xml \
- ${datadir}/navit/navit.xml \
- ${datadir}/navit/maps.xml \
- ${datadir}/navit/osd.xml \
- ${datadir}/navit/speech.xml \
- ${datadir}/navit/plugins.xml \
- "
+ ${datadir}/navit/navit.xml \
+ ${datadir}/navit/maps.xml \
+ ${datadir}/navit/osd.xml \
+ ${datadir}/navit/speech.xml \
+ ${datadir}/navit/plugins.xml \
+"
SRC_URI += "file://navit.xml \
file://maps.xml \
file://osd.xml \
file://speech.xml \
file://plugins.xml \
- "
+"
FILES_${PN} += "${libdir}/${PN}/*/*.so ${datadir}/icons"
FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug"
@@ -68,21 +68,21 @@ FILES_${PN}-graphics-gtk = " ${libdir}/${PN}/graphics/libgraphics_gtk_drawing_ar
FILES_${PN}-icons = "/usr/share/navit/xpm/"
do_configure_prepend() {
- # MOC=`$PKG_CONFIG QtGui --variable=moc_location` returns only /usr/bin/moc4 which is not available on hosts without Qt
- sed -i "s#MOC=#MOC=${STAGING_DIR_NATIVE}#g" ${S}/configure.in
+ # MOC=`$PKG_CONFIG QtGui --variable=moc_location` returns only /usr/bin/moc4 which is not available on hosts without Qt
+ sed -i "s#MOC=#MOC=${STAGING_DIR_NATIVE}#g" ${S}/configure.in
}
do_install_append() {
- # fix QA issue
- sed -i 's#Categories=GTK;Utility;Geography;#Categories=Graphics;#g' ${D}${datadir}/applications/navit.desktop
+ # fix QA issue
+ sed -i 's#Categories=GTK;Utility;Geography;#Categories=Graphics;#g' ${D}${datadir}/applications/navit.desktop
- rm ${D}${libdir}/${PN}/*/*.la
+ rm ${D}${libdir}/${PN}/*/*.la
- #Use split config
- mv ${D}${datadir}/navit/navit.xml ${D}${datadir}/navit/navit.default.xml
- install -m 0644 ${WORKDIR}/navit.xml ${D}${datadir}/navit/navit.xml
- install -m 0644 ${WORKDIR}/maps.xml ${D}${datadir}/navit/maps.xml
- install -m 0644 ${WORKDIR}/osd.xml ${D}${datadir}/navit/osd.xml
- install -m 0644 ${WORKDIR}/speech.xml ${D}${datadir}/navit/speech.xml
- install -m 0644 ${WORKDIR}/plugins.xml ${D}${datadir}/navit/plugins.xml
+ #Use split config
+ mv ${D}${datadir}/navit/navit.xml ${D}${datadir}/navit/navit.default.xml
+ install -m 0644 ${WORKDIR}/navit.xml ${D}${datadir}/navit/navit.xml
+ install -m 0644 ${WORKDIR}/maps.xml ${D}${datadir}/navit/maps.xml
+ install -m 0644 ${WORKDIR}/osd.xml ${D}${datadir}/navit/osd.xml
+ install -m 0644 ${WORKDIR}/speech.xml ${D}${datadir}/navit/speech.xml
+ install -m 0644 ${WORKDIR}/plugins.xml ${D}${datadir}/navit/plugins.xml
}
diff --git a/meta-oe/recipes-navigation/omgps/omgps_svn.bb b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
index 7c787a475a..e1c1a71d8f 100644
--- a/meta-oe/recipes-navigation/omgps/omgps_svn.bb
+++ b/meta-oe/recipes-navigation/omgps/omgps_svn.bb
@@ -10,8 +10,8 @@ PR = "r2"
S = "${WORKDIR}/${PN}"
do_configure_prepend() {
- sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am
- sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am
+ sed -i "s#PY_VERSION = 2.6#PY_VERSION = ${PYTHON_BASEVERSION}#g" ${S}/Makefile.am
+ sed -i "s#PY_INC_DIR = \$(OPIEDIR)#PY_INC_DIR = ${STAGING_DIR_HOST}#g" ${S}/Makefile.am
}
SRC_URI = "svn://omgps.googlecode.com/svn/trunk;module=omgps;protocol=http \
diff --git a/meta-oe/recipes-navigation/orrery/orrery_2.7.bb b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
index c216f29902..5c08057677 100644
--- a/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
+++ b/meta-oe/recipes-navigation/orrery/orrery_2.7.bb
@@ -18,8 +18,8 @@ SRC_URI[sha256sum] = "645166a5e05b2064ab630534a514697fc47b681951e7fe1d635c259cbd
S = "${WORKDIR}/${PN}"
do_configure_prepend() {
- # fix DSO issue with binutils-2.22
- sed -i 's/ -lrt/ -lrt -lm/g' ${S}/Makefile.am
+ # fix DSO issue with binutils-2.22
+ sed -i 's/ -lrt/ -lrt -lm/g' ${S}/Makefile.am
}
do_install_append() {
install -d ${D}${datadir}/orrery