aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-08-29 16:29:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-03 19:12:38 +0200
commit8040a4c38bd00e45d50b539affde03deddecd38c (patch)
treec130fd25c212c18d8ab93af48bdcf5efcba89027 /meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb
parentaaa03f8d129e8e316d94387d6cc9e74bf328617f (diff)
downloadmeta-openembedded-contrib-8040a4c38bd00e45d50b539affde03deddecd38c.tar.gz
qcanobserver: Move to nonworking
* depends on qwt-5 APIs, I've tried to update it to support qwt-6 which is used in meta-oe, but it looks more complicated then what I've expected, my WIP patch is here: http://git.openembedded.org/meta-openembedded-contrib/log/?h=jansa/qcanobserver if you want to finish it and move qcanobserver back to recipes-qt * qwt-5 was removed more then 1 year ago: commit 5ad3d0d042dcd3f3bf54d44144b731cd0607b2e3 Author: Eric BENARD <eric@eukrea.com> Date: Thu Apr 12 15:09:48 2012 +0000 qwt: add 6.0.1 version Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb')
-rw-r--r--meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb
new file mode 100644
index 0000000000..ef866b445c
--- /dev/null
+++ b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "The Linux CAN Sniffer"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://modeltest/LICENSE.GPL;md5=34337af480a8c452bfafe22a78fa20cb"
+
+inherit qt4x11
+
+DEPENDS += "qwt"
+
+PV = "0.5+svnr${SRCPV}"
+SRCREV = "48"
+SRC_URI = "svn://qcanobserver.svn.sourceforge.net/svnroot;module=qcanobserver;protocol=https \
+ file://0001-messagebufferinterface.cpp-add-sys-socket.h-as-inclu.patch \
+ file://0002-qconsole-writethread-gcc-4.5-fixes.patch \
+ file://candemo.xml"
+
+S = "${WORKDIR}/qcanobserver/"
+
+CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
+
+do_configure_prepend() {
+ sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro
+}
+
+do_configure_append() {
+ sed -i -e s:-L/usr/lib::g Makefile
+}
+
+do_install() {
+ install -d ${D}${datadir}/qcanobserver
+ install -d ${D}${datadir}/qcanobserver/cfg
+ install -d ${D}${datadir}/qcanobserver/lib
+ install -d ${D}${datadir}/qcanobserver/db
+
+ install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver
+
+ install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db
+ install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db
+}
+
+FILES_${PN}-dbg += "${datadir}/qcanobserver/.debug"