aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt/nonworking
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-08-29 16:29:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-03 19:12:38 +0200
commit8040a4c38bd00e45d50b539affde03deddecd38c (patch)
treec130fd25c212c18d8ab93af48bdcf5efcba89027 /meta-oe/recipes-qt/nonworking
parentaaa03f8d129e8e316d94387d6cc9e74bf328617f (diff)
downloadmeta-openembedded-contrib-8040a4c38bd00e45d50b539affde03deddecd38c.tar.gz
qcanobserver: Move to nonworking
* depends on qwt-5 APIs, I've tried to update it to support qwt-6 which is used in meta-oe, but it looks more complicated then what I've expected, my WIP patch is here: http://git.openembedded.org/meta-openembedded-contrib/log/?h=jansa/qcanobserver if you want to finish it and move qcanobserver back to recipes-qt * qwt-5 was removed more then 1 year ago: commit 5ad3d0d042dcd3f3bf54d44144b731cd0607b2e3 Author: Eric BENARD <eric@eukrea.com> Date: Thu Apr 12 15:09:48 2012 +0000 qwt: add 6.0.1 version Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt/nonworking')
-rw-r--r--meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver-socketcan_svn.bb30
-rw-r--r--meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0001-messagebufferinterface.cpp-add-sys-socket.h-as-inclu.patch41
-rw-r--r--meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0002-qconsole-writethread-gcc-4.5-fixes.patch40
-rwxr-xr-xmeta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/candemo.xml40
-rw-r--r--meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb41
5 files changed, 192 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver-socketcan_svn.bb b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver-socketcan_svn.bb
new file mode 100644
index 0000000000..9bba750086
--- /dev/null
+++ b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver-socketcan_svn.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "The Linux CAN Sniffer - SocketCAN driver"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://../../../modeltest/LICENSE.GPL;md5=34337af480a8c452bfafe22a78fa20cb"
+
+inherit qt4x11
+
+DEPENDS += "qwt libsocketcan"
+
+PV = "0.5+svnr${SRCPV}"
+SRCREV = "48"
+SRC_URI = "svn://qcanobserver.svn.sourceforge.net/svnroot;module=qcanobserver;protocol=https"
+
+S = "${WORKDIR}/qcanobserver/DeviceLib/linux/SocketCAN"
+
+CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
+
+do_configure_prepend() {
+ sed -i s:/usr/include/qwt5/:${STAGING_INCDIR}:g *.pro
+}
+
+do_install() {
+ install -d ${D}${datadir}/qcanobserver/lib
+
+ install -m 0755 ${S}/lib* ${D}${datadir}/qcanobserver/lib/
+}
+
+FILES_${PN} += "${datadir}/qcanobserver/lib"
+FILES_${PN}-dbg += "${datadir}/qcanobserver/lib/.debug"
+
diff --git a/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0001-messagebufferinterface.cpp-add-sys-socket.h-as-inclu.patch b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0001-messagebufferinterface.cpp-add-sys-socket.h-as-inclu.patch
new file mode 100644
index 0000000000..1b3da3babf
--- /dev/null
+++ b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0001-messagebufferinterface.cpp-add-sys-socket.h-as-inclu.patch
@@ -0,0 +1,41 @@
+From ebb464e3dfa2d59d65c3aa8ee652cb7607481f61 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Thu, 10 Nov 2011 19:38:27 +0100
+Subject: [PATCH] messagebufferinterface.cpp: move sys/socket.h include
+
+This prevents the following error during cross-compiling:
+
+| In file included from messagebufferinterface.cpp:30:
+| /OE/angstrom-dev/sysroots/armv7a-angstrom-linux-gnueabi/usr/include/linux/can.h:81: error: 'sa_family_t' does not name a type
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ messagebufferinterface.cpp | 7 ++++---
+ 1 files changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/messagebufferinterface.cpp b/messagebufferinterface.cpp
+index 116564c..3e9a535 100644
+--- a/messagebufferinterface.cpp
++++ b/messagebufferinterface.cpp
+@@ -25,14 +25,15 @@
+ #include <sys/time.h>
+ #include <QFile>
+
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <sys/stat.h>
++
+ //#include <linux/can.h>
+ //#include <linux/can/raw.h>
+ #include <syscall.h>
+
+ #include "configdialog.h"
+-#include <sys/types.h>
+-#include <sys/socket.h>
+-#include <sys/stat.h>
+ #include <linux/can.h>
+ #include <linux/can/raw.h>
+
+--
+1.7.2.5
+
diff --git a/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0002-qconsole-writethread-gcc-4.5-fixes.patch b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0002-qconsole-writethread-gcc-4.5-fixes.patch
new file mode 100644
index 0000000000..45619237d2
--- /dev/null
+++ b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/0002-qconsole-writethread-gcc-4.5-fixes.patch
@@ -0,0 +1,40 @@
+From 3b3cb5212b5dbf182beed171045e5d179b2e9000 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Fri, 11 Nov 2011 09:32:14 +0100
+Subject: [PATCH 2/2] qconsole, writethread: gcc 4.5 fixes
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ qconsole.cpp | 2 +-
+ writethread.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/qconsole.cpp b/qconsole.cpp
+index ea86957..b5a4687 100644
+--- a/qconsole.cpp
++++ b/qconsole.cpp
+@@ -22,7 +22,7 @@ QConsole::QConsole()
+
+ {
+ this->setReadOnly(true);
+- QTextEdit::QTextEdit(NULL);
++ QTextEdit(NULL);
+ }
+
+
+diff --git a/writethread.cpp b/writethread.cpp
+index ef7bc13..ff19560 100755
+--- a/writethread.cpp
++++ b/writethread.cpp
+@@ -69,7 +69,7 @@ void WriteThread::setDev(void *ConfData, QString InterfaceLib, bool shareDevLib)
+ if(!handle)
+ {
+ QString *ErrStr = new QString(" ");
+- ErrStr->sprintf("%s %s","Could not load Device Mapper: ", InterfaceLib);
++ ErrStr->sprintf("%s %s","Could not load Device Mapper: ", (char*)InterfaceLib.constData());
+ ErrorDialog *ed = new ErrorDialog;
+ ed->SetErrorMessage(*ErrStr);
+ delete ErrStr;
+--
+1.7.2.5
+
diff --git a/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/candemo.xml b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/candemo.xml
new file mode 100755
index 0000000000..304713fdda
--- /dev/null
+++ b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver/candemo.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+
+<Database Name="EW-demo">
+ <ID Id="180">
+ <Item0>
+ <interpret Multiplier="0.010986328125" Name="MotorPos" Offset="-180" Datamask="00120000">
+ </interpret>
+ </Item0>
+ </ID>
+ <ID Id="280">
+ <Item0>
+ <interpret Multiplier="1.0" Name="Fanstatus" Offset="0" Datamask="10000000">
+ </interpret>
+ </Item0>
+ </ID>
+ <ID Id="380">
+ <Item0>
+ <interpret Multiplier="0.00390625" Name="temp1" Offset="0" Datamask="00120000">
+ </interpret>
+ </Item0>
+ </ID>
+ <ID Id="480">
+ <Item0>
+ <interpret Multiplier="1.0" Name="fanstatus" Offset="0" Datamask="10000000">
+ </interpret>
+ </Item0>
+ </ID>
+ <ID Id="580">
+ <Item0>
+ <interpret Multiplier="1.0" Name="lampstatus" Offset="0" Datamask="10000000">
+ </interpret>
+ </Item0>
+ </ID>
+ <ID Id="680">
+ <Item0>
+ <interpret Multiplier="0.00390625" Name="Lightsensor" Offset="0" Datamask="00120000">
+ </interpret>
+ </Item0>
+ </ID>
+</Database>
diff --git a/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb
new file mode 100644
index 0000000000..ef866b445c
--- /dev/null
+++ b/meta-oe/recipes-qt/nonworking/qcanobserver/qcanobserver_svn.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "The Linux CAN Sniffer"
+
+LICENSE = "GPLv3+"
+LIC_FILES_CHKSUM = "file://modeltest/LICENSE.GPL;md5=34337af480a8c452bfafe22a78fa20cb"
+
+inherit qt4x11
+
+DEPENDS += "qwt"
+
+PV = "0.5+svnr${SRCPV}"
+SRCREV = "48"
+SRC_URI = "svn://qcanobserver.svn.sourceforge.net/svnroot;module=qcanobserver;protocol=https \
+ file://0001-messagebufferinterface.cpp-add-sys-socket.h-as-inclu.patch \
+ file://0002-qconsole-writethread-gcc-4.5-fixes.patch \
+ file://candemo.xml"
+
+S = "${WORKDIR}/qcanobserver/"
+
+CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
+
+do_configure_prepend() {
+ sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro
+}
+
+do_configure_append() {
+ sed -i -e s:-L/usr/lib::g Makefile
+}
+
+do_install() {
+ install -d ${D}${datadir}/qcanobserver
+ install -d ${D}${datadir}/qcanobserver/cfg
+ install -d ${D}${datadir}/qcanobserver/lib
+ install -d ${D}${datadir}/qcanobserver/db
+
+ install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver
+
+ install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db
+ install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db
+}
+
+FILES_${PN}-dbg += "${datadir}/qcanobserver/.debug"