aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-qt
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-contrib-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-qt')
-rw-r--r--meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb28
-rw-r--r--meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb34
-rw-r--r--meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb6
-rw-r--r--meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb18
-rw-r--r--meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb32
5 files changed, 59 insertions, 59 deletions
diff --git a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
index 9d590fdc68..c31261a4cd 100644
--- a/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
+++ b/meta-oe/recipes-qt/fingerterm/fingerterm_1.0.2.bb
@@ -12,7 +12,7 @@ PR = "r0"
inherit qt4x11 pkgconfig
SRC_URI = " \
- http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \
+ http://hqh.unlink.org/harmattan/fingerterm-${PV}.tar.gz \
"
SRC_URI[md5sum] = "d53b0f463c025583cd52accf95715448"
@@ -21,24 +21,24 @@ SRC_URI[sha256sum] = "c21a07cc411d09739bd7fa248eba2bf96427b3f032382a044b6674dd82
S = "${WORKDIR}/${PN}"
FILES_${PN} = " \
- ${bindir}/${PN} \
- ${datadir}/applications/${PN}.desktop \
- ${datadir}/pixmaps/${PN}.png \
+ ${bindir}/${PN} \
+ ${datadir}/applications/${PN}.desktop \
+ ${datadir}/pixmaps/${PN}.png \
"
do_install() {
- install -d ${D}${bindir}
- install -m 0744 ${S}/${PN} ${D}${bindir}
+ install -d ${D}${bindir}
+ install -m 0744 ${S}/${PN} ${D}${bindir}
- sed -i -e '/Exec.*/d' fingerterm.desktop
- sed -i -e '/Icon.*/d' fingerterm.desktop
+ sed -i -e '/Exec.*/d' fingerterm.desktop
+ sed -i -e '/Icon.*/d' fingerterm.desktop
- echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop
- echo 'Icon=${PN}' >> fingerterm.desktop
+ echo 'Exec=${bindir}/${PN}' >> fingerterm.desktop
+ echo 'Icon=${PN}' >> fingerterm.desktop
- install -d ${D}${datadir}/applications
- install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${S}/${PN}.desktop ${D}${datadir}/applications
- install -d ${D}${datadir}/pixmaps
- install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 ${S}/${PN}.png ${D}${datadir}/pixmaps
}
diff --git a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb
index d15d8d7608..50c149f374 100644
--- a/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb
+++ b/meta-oe/recipes-qt/libconnman-qt/libconnman-qt_0.4.0.bb
@@ -22,8 +22,8 @@ BRANCH = "master"
SRCREV = "3af5bd38d82255942f582398160a5d3354346ca3"
SRC_URI = " \
- git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \
- file://0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch \
+ git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \
+ file://0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch \
"
S = "${WORKDIR}/git"
@@ -33,37 +33,37 @@ QT_IMPORTS_DIR = "${libdir}/qt4/imports"
PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/Connman"
EXTRA_QMAKEVARS_PRE = " \
- CONFIG+=notest \
+ CONFIG+=notest \
"
do_configure_prepend() {
- # Hack *.pro variables
- find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';'
+ # Hack *.pro variables
+ find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';'
}
do_install() {
- export INSTALL_ROOT=${D}
- oe_runmake install
+ export INSTALL_ROOT=${D}
+ oe_runmake install
}
FILES_${PN} = " \
- ${libdir}/libconnman-qt4${SOLIBS} \
+ ${libdir}/libconnman-qt4${SOLIBS} \
"
FILES_${PN}-dev = " \
- ${includedir}/connman-qt/* \
- ${libdir}/libconnman-qt4${SOLIBSDEV} \
- ${libdir}/libconnman-qt4.prl \
- ${libdir}/pkgconfig/connman-qt4.pc \
- ${libdir}/connman-qt4.pc \
+ ${includedir}/connman-qt/* \
+ ${libdir}/libconnman-qt4${SOLIBSDEV} \
+ ${libdir}/libconnman-qt4.prl \
+ ${libdir}/pkgconfig/connman-qt4.pc \
+ ${libdir}/connman-qt4.pc \
"
FILES_${PN}-plugin = " \
- ${PLUGINS_TARGET}/qmldir \
- ${PLUGINS_TARGET}/lib*.so \
+ ${PLUGINS_TARGET}/qmldir \
+ ${PLUGINS_TARGET}/lib*.so \
"
FILES_${PN}-plugin-dbg = " \
- ${PLUGINS_TARGET}/.debug \
- ${PLUGINS_TARGET}/.debug/* \
+ ${PLUGINS_TARGET}/.debug \
+ ${PLUGINS_TARGET}/.debug/* \
"
diff --git a/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb b/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
index aed190cb6c..9bba750086 100644
--- a/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
+++ b/meta-oe/recipes-qt/qcanobserver/qcanobserver-socketcan_svn.bb
@@ -16,13 +16,13 @@ S = "${WORKDIR}/qcanobserver/DeviceLib/linux/SocketCAN"
CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
do_configure_prepend() {
- sed -i s:/usr/include/qwt5/:${STAGING_INCDIR}:g *.pro
+ sed -i s:/usr/include/qwt5/:${STAGING_INCDIR}:g *.pro
}
do_install() {
- install -d ${D}${datadir}/qcanobserver/lib
+ install -d ${D}${datadir}/qcanobserver/lib
- install -m 0755 ${S}/lib* ${D}${datadir}/qcanobserver/lib/
+ install -m 0755 ${S}/lib* ${D}${datadir}/qcanobserver/lib/
}
FILES_${PN} += "${datadir}/qcanobserver/lib"
diff --git a/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb b/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
index 3d79fdc6c1..ef866b445c 100644
--- a/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
+++ b/meta-oe/recipes-qt/qcanobserver/qcanobserver_svn.bb
@@ -19,23 +19,23 @@ S = "${WORKDIR}/qcanobserver/"
CXXFLAGS += " -DPF_CAN=29 -DAF_CAN=PF_CAN"
do_configure_prepend() {
- sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro
+ sed -i -e s:/usr/include/qwt5/:${STAGING_INCDIR}:g -e 's:-L/usr/lib/:-L${STAGING_DIR_TARGET}/lib -ldl:g' *.pro
}
do_configure_append() {
- sed -i -e s:-L/usr/lib::g Makefile
+ sed -i -e s:-L/usr/lib::g Makefile
}
do_install() {
- install -d ${D}${datadir}/qcanobserver
- install -d ${D}${datadir}/qcanobserver/cfg
- install -d ${D}${datadir}/qcanobserver/lib
- install -d ${D}${datadir}/qcanobserver/db
+ install -d ${D}${datadir}/qcanobserver
+ install -d ${D}${datadir}/qcanobserver/cfg
+ install -d ${D}${datadir}/qcanobserver/lib
+ install -d ${D}${datadir}/qcanobserver/db
- install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver
+ install -m 0755 ${S}/QCanObserver ${D}${datadir}/qcanobserver
- install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db
- install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db
+ install -m 0644 ${WORKDIR}/candemo.xml ${D}${datadir}/qcanobserver/db
+ install -m 0644 ${S}/db/*.xml ${D}${datadir}/qcanobserver/db
}
FILES_${PN}-dbg += "${datadir}/qcanobserver/.debug"
diff --git a/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
index da65215839..617319ab18 100644
--- a/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
+++ b/meta-oe/recipes-qt/qextserialport/qextserialport_1.2rc.bb
@@ -15,7 +15,7 @@ inherit qt4x11 pkgconfig
DEPENDS = "udev"
SRC_URI = " \
- http://qextserialport.googlecode.com/files/qextserialport-${REAL_PV}.zip \
+ http://qextserialport.googlecode.com/files/qextserialport-${REAL_PV}.zip \
"
SRC_URI[md5sum] = "ffa061edb9f64666468d18402eee6108"
@@ -26,30 +26,30 @@ S = "${WORKDIR}/qextserialport-${REAL_PV}"
FILES_${PN} = "${libdir}/libqextserialport${SOLIBS}"
FILES_${PN}-dev = " \
- ${libdir}/libqextserialport${SOLIBSDEV} \
- ${libdir}/libqextserialport.prl \
- ${includedir}/QtExtSerialPort/*.h \
- ${datadir}/qt4/mkspecs/features/extserialport.prf \
+ ${libdir}/libqextserialport${SOLIBSDEV} \
+ ${libdir}/libqextserialport.prl \
+ ${includedir}/QtExtSerialPort/*.h \
+ ${datadir}/qt4/mkspecs/features/extserialport.prf \
"
FILES_${PN}-dbg += " \
- ${libdir}/.debug/libqextserialport.so* \
+ ${libdir}/.debug/libqextserialport.so* \
"
do_configure_prepend() {
- # based on the documentation, this line make sure we use udev in linux
- cd ${S} && echo "linux*:CONFIG += qesp_linux_udev" > .qmake.cache
+ # based on the documentation, this line make sure we use udev in linux
+ cd ${S} && echo "linux*:CONFIG += qesp_linux_udev" > .qmake.cache
- # Hacking hardcoded qmake variables
- find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_HEADERS\],${includedir},g' '{}' ';'
- find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_LIBS\],${libdir},g' '{}' ';'
- find *.pro -exec sed -i -e 's,$$\[QMAKE_MKSPECS\],${datadir}/qt4/mkspecs/,g' '{}' ';'
+ # Hacking hardcoded qmake variables
+ find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_HEADERS\],${includedir},g' '{}' ';'
+ find *.pro -exec sed -i -e 's,$$\[QT_INSTALL_LIBS\],${libdir},g' '{}' ';'
+ find *.pro -exec sed -i -e 's,$$\[QMAKE_MKSPECS\],${datadir}/qt4/mkspecs/,g' '{}' ';'
}
do_install() {
- export INSTALL_ROOT=${D}
- oe_runmake install
+ export INSTALL_ROOT=${D}
+ oe_runmake install
- # This is necessary to make it work with the qt based SDK
- cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|${STAGING_INCDIR_NATIVE}/qt4|\$(OE_QMAKE_INCDIR_QT)/..|" ./extserialport.prf
+ # This is necessary to make it work with the qt based SDK
+ cd ${D}/${datadir}/qt4/mkspecs/features && sed -i -e "s|${STAGING_INCDIR_NATIVE}/qt4|\$(OE_QMAKE_INCDIR_QT)/..|" ./extserialport.prf
}