aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-qt
diff options
context:
space:
mode:
authorFelipe F. Tonello <ftonello@cercacor.com>2013-02-11 17:25:53 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-19 01:48:45 +0100
commitf4052df881190557b8037d15bd1cdf54bacf96ca (patch)
treec5276aee621ee33ed12447861c54122e9dea577a /meta-oe/recipes-qt
parentcb4ac55a33d1964042ee9a3d277ea10573e23664 (diff)
downloadmeta-openembedded-contrib-f4052df881190557b8037d15bd1cdf54bacf96ca.tar.gz
connman: added recipe libconnman-qt
This recipe provides the Qt library and QML plugins for connman. MJ: exported INSTALL_ROOT to fix build with dash MJ: dropped AUTOREV MJ: dropped TAG and replaced with SRCREV for 0.4.0 Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-qt')
-rw-r--r--meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch37
-rw-r--r--meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb69
2 files changed, 106 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch
new file mode 100644
index 0000000000..6ec084d90b
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt/0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch
@@ -0,0 +1,37 @@
+From 3850acef7d914a22e3fc4130ad43b2cc47338d6f Mon Sep 17 00:00:00 2001
+From: "Felipe F. Tonello" <ftonello@cercacor.com>
+Date: Mon, 7 Jan 2013 17:13:22 -0800
+Subject: [PATCH] added flags to disable qml plugin and test program to
+ compile
+
+This is usefull when there is no need to compile test program and qml plugin.
+
+Upstream-Status: Accepted
+
+Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com>
+---
+ connman-qt.pro | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/connman-qt.pro b/connman-qt.pro
+index 7d9ec99..425c41f 100644
+--- a/connman-qt.pro
++++ b/connman-qt.pro
+@@ -1,4 +1,13 @@
+ TEMPLATE = subdirs
+-SUBDIRS += libconnman-qt test plugin
++SUBDIRS += libconnman-qt
+ CONFIG += ordered
+
++# CONFIG flag to disable test program
++!notest {
++ SUBDIRS += test
++}
++
++# CONFIG flag to disable qml plugin
++!noplugin {
++ SUBDIRS += plugin
++}
+--
+1.7.9.5
+
diff --git a/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb
new file mode 100644
index 0000000000..d15d8d7608
--- /dev/null
+++ b/meta-oe/recipes-qt/libconnmna-qt/libconnman-qt_0.4.0.bb
@@ -0,0 +1,69 @@
+DESCRIPTION = "Qt Library for ConnMan"
+HOMEPAGE = "https://github.com/nemomobile/libconnman-qt"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88"
+
+SECTION = "qt/lib"
+
+PR = "r0"
+
+inherit qt4x11 pkgconfig
+
+RDEPENDS_${PN} = "connman"
+RDEPENDS_${PN}-plugin = "${PN}"
+
+PROVIDES += "${PN}-plugin"
+
+PACKAGES =+ "${PN}-plugin ${PN}-plugin-dbg"
+RRECOMMENDS_${PN} = "${PN}-plugin"
+
+BRANCH = "master"
+# this matches 0.4.0 tag
+SRCREV = "3af5bd38d82255942f582398160a5d3354346ca3"
+
+SRC_URI = " \
+ git://github.com/nemomobile/${PN}.git;branch=${BRANCH} \
+ file://0001-added-flags-to-disable-qml-plugin-and-test-program-t.patch \
+"
+
+S = "${WORKDIR}/git"
+
+QT_IMPORTS_DIR = "${libdir}/qt4/imports"
+# the plugin target needs to be the same as 'target.path' and 'qmldir.path' in ${S}/plugin/plugin.pro
+PLUGINS_TARGET = "${QT_IMPORTS_DIR}/MeeGo/Connman"
+
+EXTRA_QMAKEVARS_PRE = " \
+ CONFIG+=notest \
+"
+
+do_configure_prepend() {
+ # Hack *.pro variables
+ find ${S}/plugin/*.pro -exec sed -i -e 's,$$\[QT_INSTALL_IMPORTS\],${QT_IMPORTS_DIR},g' '{}' ';'
+}
+
+do_install() {
+ export INSTALL_ROOT=${D}
+ oe_runmake install
+}
+
+FILES_${PN} = " \
+ ${libdir}/libconnman-qt4${SOLIBS} \
+"
+
+FILES_${PN}-dev = " \
+ ${includedir}/connman-qt/* \
+ ${libdir}/libconnman-qt4${SOLIBSDEV} \
+ ${libdir}/libconnman-qt4.prl \
+ ${libdir}/pkgconfig/connman-qt4.pc \
+ ${libdir}/connman-qt4.pc \
+"
+
+FILES_${PN}-plugin = " \
+ ${PLUGINS_TARGET}/qmldir \
+ ${PLUGINS_TARGET}/lib*.so \
+"
+
+FILES_${PN}-plugin-dbg = " \
+ ${PLUGINS_TARGET}/.debug \
+ ${PLUGINS_TARGET}/.debug/* \
+"