aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bash-completion
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-03-12 14:25:46 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-03-18 20:04:57 +0100
commit412ef2ced97ecc6c60294711d2bade02e0960882 (patch)
tree169bd7d04f0ecd97b3590a90988e54805cbb6109 /meta-oe/recipes-support/bash-completion
parente152744d3e4388b8049a78216b46512afb2f9cc3 (diff)
downloadmeta-openembedded-contrib-412ef2ced97ecc6c60294711d2bade02e0960882.tar.gz
bash-completion: update to version 2.1
Notes: - PARALLEL_MAKE is still required - inherit allarch is not present because of runtime dependency with bash (TUNE_PKGARCH) Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/bash-completion')
-rw-r--r--meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb (renamed from meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb)11
1 files changed, 5 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb b/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
index ad7fd28c42..9a0ff352d0 100644
--- a/meta-oe/recipes-support/bash-completion/bash-completion_2.0.bb
+++ b/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
@@ -5,26 +5,25 @@ BUGTRACKER = "https://alioth.debian.org/projects/bash-completion/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-PR = "r1"
-
SECTION = "console/utils"
SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
-SRC_URI[md5sum] = "0d903f398be8c8f24bc5ffa6f86127f8"
-SRC_URI[sha256sum] = "e5a490a4301dfb228361bdca2ffca597958e47dd6056005ef9393a5852af5804"
+SRC_URI[md5sum] = "4e2a9f11a4042a38ee79ddcd048e8b9e"
+SRC_URI[sha256sum] = "2b606804a7d5f823380a882e0f7b6c8a37b0e768e72c3d4107c51fbe8a46ae4f"
PARALLEL_MAKE = ""
-inherit allarch autotools
+inherit autotools
do_install_append() {
+ # compatdir
install -d ${D}${sysconfdir}/bash_completion.d/
echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
# Delete files already provided by util-linux
local i
- for i in cal dmesg hwclock ionice look renice rtcwake; do
+ for i in cal dmesg eject hexdump hwclock ionice look renice rtcwake; do
rm ${D}${datadir}/${BPN}/completions/$i
done
}