aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/canonical-multitouch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-10-18 22:38:23 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-26 10:28:38 +0200
commit73c68712737e17d5166189d54a17a8107175c2dc (patch)
tree301feac4c70b56842dae3b424cc4a021b6b94ef3 /meta-oe/recipes-support/canonical-multitouch
parent2280f696f85d1a751b0163770599e227b62a3b55 (diff)
downloadmeta-openembedded-contrib-73c68712737e17d5166189d54a17a8107175c2dc.tar.gz
frame: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/canonical-multitouch')
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch27
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb3
2 files changed, 29 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch b/meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch
new file mode 100644
index 0000000000..aa5a56ab87
--- /dev/null
+++ b/meta-oe/recipes-support/canonical-multitouch/frame/pessimizing-move.patch
@@ -0,0 +1,27 @@
+let compiler decide on copy elision
+Fixes compiler errors with clang
+| ../../frame-2.5.0/src/x11/device_x11.cpp:126:13: error: moving a temporary object prevents copy elision [-Werror,-Wpessimizing-move]
+| std::move(UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis)));
+| ^
+| ../../frame-2.5.0/src/x11/device_x11.cpp:126:13: note: remove std::move call here
+| std::move(UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis)));
+| ^~~~~~~~~~ ~
+| 1 error generated.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: frame-2.5.0/src/x11/device_x11.cpp
+===================================================================
+--- frame-2.5.0.orig/src/x11/device_x11.cpp
++++ frame-2.5.0/src/x11/device_x11.cpp
+@@ -122,8 +122,7 @@ UFDeviceX11::UFDeviceX11(Display* displa
+ UFAxis_* axis = new UFAxis(type, valuator_info->min, valuator_info->max,
+ valuator_info->resolution);
+
+- axes_[type] =
+- std::move(UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis)));
++ axes_[type] = UniqueUFAxis(static_cast<oif::frame::UFAxis*>(axis));
+
+ axis_map_[valuator_info->number] = type;
+
diff --git a/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb b/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb
index ecc95247ad..0ad10a4ca2 100644
--- a/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/frame_2.5.0.bb
@@ -10,7 +10,8 @@ LIC_FILES_CHKSUM = " \
inherit autotools pkgconfig
-SRC_URI = "https://launchpad.net/${BPN}/trunk/v${PV}/+download/${BPN}-${PV}.tar.gz"
+SRC_URI = "https://launchpad.net/${BPN}/trunk/v${PV}/+download/${BPN}-${PV}.tar.gz \
+ file://pessimizing-move.patch"
SRC_URI[md5sum] = "02baa941091c5d198cd1623b3ad36e68"
SRC_URI[sha256sum] = "cfb9ab52cdccd926f1822a457264d0014c7eb9f4600a72626063dd073b26256f"