aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.6.bb
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2015-01-13 21:19:42 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-01-20 16:06:14 +0100
commit4ec551cd35782add19eab976859f5dcbab5cefd9 (patch)
tree859dfd263b72ed2ba77a37f63f51ddd3e7295919 /meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.6.bb
parente9110f6f885d25371623352f8c5566e3cfc1bd89 (diff)
downloadmeta-openembedded-contrib-4ec551cd35782add19eab976859f5dcbab5cefd9.tar.gz
cryptsetup: update 1.6.2 -> 1.6.6
Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.6.bb')
-rw-r--r--meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.6.bb b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.6.bb
new file mode 100644
index 0000000000..d84ad2f074
--- /dev/null
+++ b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.6.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Manage plain dm-crypt and LUKS encrypted volumes"
+DESCRIPTION = "Cryptsetup is used to conveniently setup dm-crypt managed \
+device-mapper mappings. These include plain dm-crypt volumes and \
+LUKS volumes. The difference is that LUKS uses a metadata header \
+and can hence offer more features than plain dm-crypt. On the other \
+hand, the header is visible and vulnerable to damage."
+HOMEPAGE = "http://code.google.com/p/cryptsetup/"
+SECTION = "console"
+LICENSE = "GPL-2.0-with-OpenSSL-exception"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326"
+
+DEPENDS = "util-linux lvm2 popt libgcrypt"
+
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v1.6/${BP}.tar.xz"
+SRC_URI[md5sum] = "179c0781de59838a4e39f61b2df5ea48"
+SRC_URI[sha256sum] = "2d2ce28e4e1137dd599d87884b62ef6dbf14fd7848b2a2bf7d61cf125fbd8e6f"
+
+inherit autotools gettext pkgconfig
+
+# Use openssl because libgcrypt drops root privileges
+# if libgcrypt is linked with libcap support
+PACKAGECONFIG ??= "openssl"
+PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl"
+PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt"
+
+RRECOMMENDS_${PN} = "kernel-module-aes-generic \
+ kernel-module-dm-crypt \
+ kernel-module-md5 \
+ kernel-module-cbc \
+ kernel-module-sha256-generic \
+"
+
+EXTRA_OECONF = "--enable-static"