aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cryptsetup/cryptsetup_1.7.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-08-09 17:50:41 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-15 12:31:59 +0200
commit5f9728d97f65173833f9d9aa2f535172f222c844 (patch)
treefcba9a39e43c40ced854f0f9a440e6bda829d503 /meta-oe/recipes-support/cryptsetup/cryptsetup_1.7.2.bb
parent7151a9d71fd87b95ffa02013b7b2f47a4d328738 (diff)
downloadmeta-openembedded-contrib-5f9728d97f65173833f9d9aa2f535172f222c844.tar.gz
cryptsetup: update to version 1.7.2
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cryptsetup/cryptsetup_1.7.2.bb')
-rw-r--r--meta-oe/recipes-support/cryptsetup/cryptsetup_1.7.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cryptsetup/cryptsetup_1.7.2.bb b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.7.2.bb
new file mode 100644
index 0000000000..d160a09326
--- /dev/null
+++ b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.7.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Manage plain dm-crypt and LUKS encrypted volumes"
+DESCRIPTION = "Cryptsetup is used to conveniently setup dm-crypt managed \
+device-mapper mappings. These include plain dm-crypt volumes and \
+LUKS volumes. The difference is that LUKS uses a metadata header \
+and can hence offer more features than plain dm-crypt. On the other \
+hand, the header is visible and vulnerable to damage."
+HOMEPAGE = "http://code.google.com/p/cryptsetup/"
+SECTION = "console"
+LICENSE = "GPL-2.0-with-OpenSSL-exception"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326"
+
+DEPENDS = "util-linux lvm2 popt libgcrypt"
+
+SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v1.7/${BP}.tar.xz"
+SRC_URI[md5sum] = "a11a140cea496961222170944db01fc1"
+SRC_URI[sha256sum] = "dbb35dbf5f0c1749168c86c913fe98e872247bfc8425314b494c2423e7e43342"
+
+inherit autotools gettext pkgconfig
+
+# Use openssl because libgcrypt drops root privileges
+# if libgcrypt is linked with libcap support
+PACKAGECONFIG ??= "openssl"
+PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl"
+PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt"
+
+RRECOMMENDS_${PN} = "kernel-module-aes-generic \
+ kernel-module-dm-crypt \
+ kernel-module-md5 \
+ kernel-module-cbc \
+ kernel-module-sha256-generic \
+"
+
+EXTRA_OECONF = "--enable-static"