aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/digitemp/digitemp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-11-25 16:37:09 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-25 20:53:06 +0100
commit639323c998a8c53eef864bcde091c6e0bd2dc00a (patch)
tree3294ccce896d3d62d0794f34f12f901609aa3692 /meta-oe/recipes-support/digitemp/digitemp
parent8130a2f78cfec19f5d0e829bdec133a39e2672fd (diff)
downloadmeta-openembedded-contrib-639323c998a8c53eef864bcde091c6e0bd2dc00a.tar.gz
digitemp: fix build for non x86 architectures
* fix Makefile to allow CC and CFLAGS override * clean binaries before build Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/digitemp/digitemp')
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
new file mode 100644
index 0000000000..c0d552d541
--- /dev/null
+++ b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
@@ -0,0 +1,20 @@
+digitemp: allow override of CC and CFLAGS vars
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+
+--- a/Makefile 2008-08-28 21:37:00.000000000 +0000
++++ b/Makefile 2011-11-24 22:22:39.882511272 +0000
+@@ -11,8 +11,9 @@
+
+ VERSION = 3.6.0
+
+-CC = gcc
+-CFLAGS = -I./src -I./userial -O2 -Wall # -g
++CC ?= gcc
++CFLAGS ?= -O2 -Wall # -g
++CFLAGS += -I./src -I./userial
+
+ OBJS = src/digitemp.o src/device_name.o src/ds2438.o
+ HDRS = src/digitemp.h src/device_name.h