aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/emacs
diff options
context:
space:
mode:
authorAlexandre Tuleu <alexandre.tuleu.2005@polytechnique.org>2013-11-07 18:21:17 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-11-18 23:14:09 +0100
commita64bd5b7e4e95d71c8dd5439ac30f2e3fbcff77a (patch)
tree0afa42c1676d7161f790085e912a7154abd3e9ff /meta-oe/recipes-support/emacs
parent4580f49afe7d974f279eae766c0171aeb208689a (diff)
downloadmeta-openembedded-contrib-a64bd5b7e4e95d71c8dd5439ac30f2e3fbcff77a.tar.gz
emacs: Allows non-x11 build on distribution supporting x11
By default emacs will build with x11 if the distribution has x11 support. However in a .bbappend file a user could strip away x11 support, even if x11 is supported on the platform. There was another check in do_compile_prepend() that checked if the distro has x11 feature and not if PACAKAGECONFIG enables x11 support. Since in this receipe dbus dependence is only marked if x11 is enabled, desactiving x11 support should also desactivate dbus support. Signed-off-by: Alexandre Tuleu <alexandre.tuleu.2005@polytechnique.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/emacs')
-rw-r--r--meta-oe/recipes-support/emacs/emacs.inc5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/emacs/emacs.inc b/meta-oe/recipes-support/emacs/emacs.inc
index fa554ed738..d7d281f46e 100644
--- a/meta-oe/recipes-support/emacs/emacs.inc
+++ b/meta-oe/recipes-support/emacs/emacs.inc
@@ -19,7 +19,8 @@ X11DEPENDS = " \
EXTRA_OECONF = "--without-sound --with-crt-dir=${STAGING_LIBDIR} "
PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
-PACKAGECONFIG[x11] = "--with-x-toolkit=gtk,--without-x,${X11DEPENDS}"
+PACKAGECONFIG[x11] = "--with-x-toolkit=gtk,--without-x --without-dbus,${X11DEPENDS}"
+
inherit autotools
@@ -87,7 +88,7 @@ do_compile_prepend() {
${STAGING_DIR_TARGET}/${base_libdir}/libgcc_s.so.* \
${STAGING_DIR_TARGET}/${base_libdir}/libpthread* $treedir/${base_libdir}/
- if [ ! -z "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" ] ; then
+ if [ ! -z "${@base_contains('PACKAGECONFIG', 'x11', 'x11', '', d)}" ] ; then
echo "X11 build enabled"
# copy only as much stuff as we need
# before: 5.5G ../../qemu-treedir/